Paging Pro Issues

I have a FreePBX system with the paging Pro module installed. I have the Multicast setup on the templates and also have 2-page groups going to and They are able to page fine from the phones using the Multicast Button but the issue is that I have certain extensions selected but it still pages on all phones, not the ones I selected. Any thoughts on how to fix this?

No one else has ever had this issue? I need to get this figured out as the Client is starting to get annoyed.

AFAIK, this is how multicast works. The idea is that the PBX doesn’t have to place x amount of calls to page but rather place one call and anyone who “listens” will get it.

If your want to page a certain group of device, either setup a new multicast or use regular paging.

the point of being able to select the phones I want to listen to should only go to those phones that I select right? If so it’s not doing that it’s going to all the phones that have the multicast IP configured in the phone template.

No that is not how it works. The phones you pick there FreePBX will send a unicast page to. The multicast is sent to the IP:Port and any device programmed to listen to that will get the page. You can not stop a phone setup to listen on that from getting the page.

What is the purpose of selecting the extensions then? and so basically I just need to create different Templates for the Page group and add the template to that phone to work the way I am speaking of.

AFAIK, to allow you to include additional phones other than Multicast. For example, if you want to include some remote phones, etc.

So the ring before the page is broadcasted the client wants that to be changed to a beep. So all they want to hear is the beep then message. Is that possible or will it always ring tone?


That doesnt tell me anything. I am saying that its already set to beep and default for the beep but it is not when paging multicast. If I page using the none multicast by hitting 6000 then the beep is there but not in multicast.

You have not specified which telephone manufacturer and set type you are using. Multicast and set beeps are very different on each type of phone.

Multicast paging and extension paging are two different things. If you want the phones to beep when multicast occurs, you need to set it in the phone. The downside is that if you do a set page to those phones, they will play the set’s own beep and then the paging beep which is part of FreePBX.

You are better off just setting up individual phones in each paging group and forget about multicast unless you want it for system-wide emergency paging.

They all use the S705 and I have to do multicast because there are too many phones that need to receive the page. This is for a hospital as they use Paging all the time and just now complaining about that ring before the page that they want to be changed to the Beep.

So there is no way of Getting rid of the Ring unless I do like a Paging server then I take it?

I feel certain you can turn off the phone’s local ring before a page. I don’t have Sangoma phones and haven’t found an online administration manual for them but you might direct that question to Sangoma support for assistance.

If you’re not getting an answer here, ask Sangoma about their phone, they would know best.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.