Paging not working - but Intercom does...Grandstream GPX2135/2170

Anybody Else seeing this? - It just started recently - it WAS working perfectly and then suddenly stopped - when you do the Page, the phones ring like they are being called but they never auto-answer - but *80Extension works perfectly - I thought they used the same method to force the phone off-hook.

Latest Firmware in EPM - Any ideas?


Is your page group set to ring only versus auto answer?


I recall seeing here on the community that there were some major fixes in the paging module edge version. Have you tried upgrading?
Before upgrading note the current version in case you need to roll back.

Good idea but no - had 14.0.8 - Upgraded to 14.0.12 - Same thing - I am going onsite with a Hub and WireShark - since Intercom works but Paging doesn’t, I am guessing it is sending different AlertInfo messages - the correct one for Grandstream’s during Intercom and the wrong one during Page’s. I will post results here in a minute.

Yup - That is the problem - Here is the invite on an Intercom Call:


Here is the invite on a Page:


Why would it not be sending the Ring Answer on the Page, but it does on the Intercom? Just noticed it’s not sending the Call-Info either - I don’t know how that field is used, but it is a difference in the invites.

What happens when you set “Busy Extensions” to “Force”?

Before submitting a bug report, I would first downgrade to Asterisk 13 and test.

This is almost worse than the problem - per the suggestion above, reverted to Asterisk 13 and set Busy Extensions to force and Wha-lah:


But then, never being one to leave well enough alone, I turned off Force and reverted to Asterisk 16 and tested again:


An now it’s working - what do they call this - “Fixed in testing” - I hate that!

Maybe switching versions (several times) fixed it? Beats me!

1 Like

Problems that go away by themselves come back by themselves.

1 Like

Yup - that is what I am worried about…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.