Paging and Intercom help

FREEPBX Firmware: 4.211.64-7
PBX Service Pack: 1.0.0.0
Asterisk: 11.5.1
(sangoma PRI card installed, A101DE)

Paging is enabled and works fine when I dial *80xxx (where xxx is extension number).

I would like to setup a Page group with an extension (say 901) that pages all of the phones. After configuring the group (no matter if 15 extensions or 1 extension) I cannot dial the paging extension.

When attempting to page from a given phone:

My grandstream phone gives a “Call Failed” “Reason Code 603”

My YeaLink phone gives a “Declined”

the asterisk command line gives:
WARNING[17525][C-00000c6b]: pbx.c:6390 __ast_pbx_run: Channel ‘SIP/110-00002464’ sent to invalid extension but no invalid handler: context,exten,priority=outbound-allroutes,901,2

What am I missing in setting up a paging/intercom group?

Thanks.

Sounds like you have it configured correctly but to verify. You have created a page group and set the Paging Extension to 901. You picked the extensions in that page group. You dial 901 and it does not page any of the phones?

Do you have anything in your outbound routes that 901 could be matching? Have you tried setting up a page group with a different number?

You have something wrong because it’s trying to send 901 to your outbound trunk.

I did have a potential matching outbound route (X.) but there would have to have been a 8 prepended to it… I have removed that route, but the same problem exists.

I have changed the page group (currently only 1 line in the grouup) to 7000 and I get the same result:

– Executing [[email protected]:3] GotoIf(“SIP/134-000027f2”, “0?,7000,2:outbound-allroutes,7000,2”) in new stack
– Goto (outbound-allroutes,7000,2)
[2013-10-03 09:43:16] WARNING[6498][C-00000e2d]: pbx.c:6390 __ast_pbx_run: Channel ‘SIP/134-000027f2’ sent to invalid extension but no invalid handler: context,exten,priority=outbound-allroutes,7000,2

I am waiting on the phones to die down a bit to do an asterisk restart to see if that helps.

Any other ideas?

Sorry… I meant prefix… not prepend on the above statement…

And you can dial extension to extension? What do your extension numbers look like…ie, what range and I’d sure like to see the matching patterns in your outbound routes. As I think I intimated and Skyking said, there really seems to be a problem somewhere in the outbound routes where your paging is being intercepted and pushed to an outbound route.

BF

Extensions are in the ranges:
100-199 for phones
400-410 for ATAs (fax machines ect…)
900-999 for virtual extensions…

I can use *80ext to direct intercom a line, just not a group

I have tried setting the group extension to 7000, 601, 602…

It does seem like it is attempting to use an outbound route, but I do not see where my outbound routes may be getting in the way.

Any better ways of troubleshooting this problem?

outbound routes (PRI lines)
1NXXNXXXXXX
911
NXXXXXX
9NXXNXXXXXX
9911
9NXXXXXX

Outbound routes (SIP trunk):
81NXXNXXXXXX
8NXXNXXXXXX

The phones seem to be functioning normally other than this issue (it has not become an issue yet, since this is a feature we only use once a month)

Yeah post the output of the asterisk command dialplan show [email protected] or whatever your page extension is set to.

With those routes I don’t even see how it got to the context.

dialplan show [email protected]
[ Included context ‘set-alert-if-local’ created by ‘pbx_config’ ]
’_.’ => 1. Goto(from-internal-original,${EXTEN},1) [pbx_config]

[ Included context ‘ext-paging’ created by ‘pbx_config’ ]
‘602’ => hint: Custom:PAGE602 [pbx_config]
1. Goto(app-pagegroups,602,1) [pbx_config]

[ Included context ‘outbound-restricted-routes’ created by ‘pbx_config’ ]
’_X.’ => 1. Macro(user-callerid,LIMIT) [pbx_config]
2. Set(ROUTEUSER=${IF($["${EXTTOCALL}"!=""]?${EXTTOCALL}:${AMPUSER})}) [pbx_config]
3. GotoIf($[${LEN(${ROUTEUSER})}>0 & ${DB_EXISTS(AMPUSER/${ROUTEUSER}/outroute)}]?${DB(AMPUSER/${ROUTEUSER}/outroute)},${EXTEN},2:outbound-allroutes,${EXTEN},2) [pbx_config]

[ Included context ‘bad-number’ created by ‘pbx_config’ ]
’_X.’ => 1. ResetCDR() [pbx_config]
2. NoCDR() [pbx_config]
3. Progress() [pbx_config]
4. Wait(1) [pbx_config]
5. Progress() [pbx_config]
6. Playback(silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer) [pbx_config]
7. Wait(1) [pbx_config]
8. Congestion(20) [pbx_config]
9. Hangup() [pbx_config]

-= 4 extensions (15 priorities) in 4 contexts. =-

HMMMM…

Where is this coming from?

[ Included context ‘outbound-restricted-routes’ created by ‘pbx_config’ ]
’_X.’ => 1. Macro(user-callerid,LIMIT) [pbx_config]
2. Set(ROUTEUSER=${IF($["${EXTTOCALL}"!=""]?${EXTTOCALL}:${AMPUSER})}) [pbx_config]
3. GotoIf($[${LEN(${ROUTEUSER})}>0 & ${DB_EXISTS(AMPUSER/${ROUTEUSER}/outroute)}]?${DB(AMPUSER/${ROUTEUSER}/outroute)},${EXTEN},2:outbound-allroutes,${EXTEN},2) [pbx_config]

BF

That’s FreePBX generated. It does look like 602 is linked to the paging group.

But why the outbound restricted routes context?

BF

That’s a Philippe question but I think that it would be from the extension routing module.

I wonder if it is just related to this version of FreePBX? Does anyone else have another version of FreePBX installed that they could setup a paging group on?