Page Group calls ringing Poly devices, not answering

System Info:
PBX Version:
PBX Distro: 12.7.8-2302-1.sng7
Asterisk Version: 18.16.0

A number of my users have requested a feature that they used a long time ago where they could broadcast a message to the whole company from their phone by dialing some number. I’ve come to figure out that what they’re referring to was a Paging Group.

I’ve reviewed our Paging Group settings and for science created a test group (x251) that only contains one phone (extension 245). I am using another device (extension 221) to test. All Poly devices.

What happens is when I dial the Page Group number (251) from device 221, the target phone (245) rings for about two seconds and then stops ringing - it does not pick up. At the same time, on device 221 which I’m calling from, I hear the custom Alert Tone I set, then a beep, and then silence. This call stays up until I hang it up.

If I do the same thing but I immediately answer the ringing 245 device (and not let it stop ringing after two seconds), it seems to work as intended. I hear the custom Alert Tone through 245, and then whatever I speak into 221 comes out of 245.

I should note that I recently upgraded all of our phones from a hodgepodge of Linksys, Cisco, Aastra, Mitel, and Poly devices. We now have newer Poly VVX350s and VVX450s everywhere.

For testing, I added an older Linksys phone to the ring group. This works properly - the phone answers instantly and starts playing the audio stream.

So, why are the Poly phones not automatically answering the page when it comes in? Do Poly phones not support Paging? Is there some change I need to make in order for the Poly devices to automatically answer? They have a setting for auto-answer SIP calls, but then all calls pick up automatically, I only want Pages to pick up automatically.

I’m sure there’s something simple I’m overlooking. Thank you!

What does your phone config look like? Is it the default config from Poly or is it a config generated from Freepbx EPM(or custom)?

Pretty much just the default config on the phones. I’ve updated to latest firmware, changed the admin password, changed the time zone, updated SIP server and Outbound Proxy to our PBX server, and SIP Line Identification details on each phone to the user’s details (name, extension, secret, label).

Aside from that all the configuration on these devices is whatever default is.

I do not currently have the Endpoint Manager plugin, though I have been considering purchasing it

Note: I found this reddit thread where the poster was having the same problem, but no solutions found as far as I can tell. Something about the Poly phones needing to receive the Page header differently maybe?

I think I fixed it…

I found this in another post. I exported the current configuration file, added these lines to the end of it, and then reuploaded to my device:

voIpProt.SIP.alertInfo.1.value=“Auto Answer”

Now it’s working correctly. So… now how do I make this change on 40 phones…

There has been others post how they setup to distribute their custom configs, which seems to work fine. Easy workaround is buy Endpoint Manager from FreePBX/Sangoma, it is a great tool. I do feel like it has lacked updates for adding various phone models lately. I believe it does have VVX 350 and 450 on the latest version though.

Cool. I’m just gonna do that. May as well support FreePBX. Thanks!

As an alternative, Polycoms and FreePBX can both use multicasting instead of paging at a much lower ‘cost’ for company wide broadcasts if IGMP is routeable to all devices