P-Prefered-Identity required

Hi,

my outgoing CID is not accepted by my SIP provider (sipgate).
They told me, I send a P-Asserted-Identity, but require a P-Prefered-Identity. And the domain at the end of the string is wrong.

This is what the FreePBX send at the moment:
P-Asserted-Identity: sip:[email protected]

Thats what I require to send:
P-Prefered-Identity: sip:[email protected]

How can I set this P-Prefered-Identity? And how to setup the Domain at the end of this string?
I do not set the domain “sipgate.net” anywhere. Dont know where it comes from.

Kind regards,

Marco

check your trunk settings. what are you using as the host=?

also check the register string is correct

check your trunk settings. what are you using as the host=?
The host setting in the Trunk -> PEER Details is setup to: host=sipconnect.sipgate.de

also check the register string is correct
username:[email protected]/username

Think it should be working, but it doesn’t.

what do you get if you ping sipconnect.sipgate.de ?

The ping seems to be correct.

[[email protected] asterisk]# ping sipconnect.sipgate.de
PING sipconnect.sipgate.de (217.10.68.150) 56(84) bytes of data.
64 bytes from sipconnect.sipgate.de (217.10.68.150): icmp_seq=1 ttl=53 time=30.6 ms

I shoud say, I use the FreePBX Beta version 3.211.63-3. Maybe something is wrong there.

ok. try setting the host=217.10.68.10

also change the register string to username:[email protected]/username

then goto the CLi and do a sip reload

Does not work. With host=217.10.68.10 asterisk can not login.
What is it for a host? A nslookup told me: anubis.netzquadrat.de

He had a type meant 217.10.68.150, what the IP resolved to in your test.

yes, sorry I meant 217.10.68.150

Okay. No changes after the hostname / IP change. The outgoing CID is not accepted. But I dont know if it is because of the missing P-Prefered-Identity or because of the wrong hostname in the P-Prefered-Identity string (@sipgate.net). I need to call the provider to ask him if he can tell me the header.

Is it possibe to see header on outgoing calls myself?

Additional information:

My trunk settings before the hostname/ip changes:

Trunk Name: Sipgate-TR1

PEER Details:

username=USERNAME
type=peer
secret=PASSWORD
registertimeout=600
qualify=yes
port=5060
outboundproxy=sipconnect.sipgate.de
insecure=port,invite
host=sipconnect.sipgate.de
fromdomain=sipconnect.sipgate.de
dtmfmode=rfc2833
disallow=all
canreinvite=no
allow=alaw
fromuser=1380218t0
sendrpid=pai
trustrpid=no

USER Context: USERNAME

username=USERNAME
secret=PASSWORD
qualify=yes
insecure=very
fromdomain=sipconnect.sipgate.de
dtmfmode=info
disallow=all
allow=alaw
fromuser=USERNAME
sendrpid=pai
trustrpid=no
host=sipconnect.sipgate.de

Register String:
USERNAME:[email protected]/USERNAME