Overlapping port

Hello everyone,

So I have already post this same question before but it did not fixed the problem. So the error is “An unknown port conflict has been detected in PJSIP. Please check and validate your PJSIP Ports to ensure they’re not overlapping”

I have restart the asterisk and also checked if there bind port is conflicting. The ports on not same so no conflict and i have restart the asterisk using the “fwconsole restart” on the console. I don’t think that fixed the problem… Can anyone please help me please.

Not without more information. Something in your system (that we can’t see) is causing a port conflict. It’s not a feature of the system. We didn’t do it, and you haven’t told us anything more than “That didn’t work - guess again.”

More info = more answers.


I apologize asking the question without giving much of information. The the previous programmer was doing this in our company to set everything up from the scratch and he left the company and the company wanted me to finish what he has started. When i took his project i had no idea where to start and don’t know how all the asterisk and freepbx worked together. I will provide the information below and hopefully this is enough information. Again i apologize.

Port to Listen On: 5060

Chan Sip
Bind Port: 5160
TLS Bind Port: 5161

Okay also i checked if the state is in listen for the port 5060 and 5160. I do not think that the state is in LISTEN for both port. I checked it by going to the putty.

Thank You

Try ‘nmap -sU localhost’ and see what that pops up.

Something, somewhere on your system has port 5060 open. The fact that it should be Asterisk and clearly isn’t (because that’s what the error means) means that you have something else that “someone else” set up to use that port.

Another possibility - if you are starting the Asterisk server twice (once from ‘service asterisk start’ and once from inetd.d for example) then it could be a simple matter of not starting the second Asterisk.

1 Like

Hello again

So like you said i did run the cmd on the putty and this is the result that it returned back to me. I will post an image below.

Thank You

Also i checked using the “netstat -tulpn”. And i see both port of 5060 and 5160, both UDP.

That tells me you have another Asterisk running somewhere.

1 Like

Do you have an endpoint in pjsip.endpoint.conf called anonymous with transport=udp,tcp,ws,wws like this?


That would explain the “Unable to retrieve PJSIP transport” error that you have posted.

As far as the port conflict goes, I would check if there are any custom transports in pjsip.transports_custom_post.conf or pjsip.transports_custom.conf that might be causing conflicts with what you have configured.

Also I would look inside pjsip.transports.conf.

1 Like

Hello avayax,

So i did a screen shot of the pjsip.endpoint.conf picture below


pjsip.transports_custom_post.conf and pjsip.transports_custom.conf is empty…

Also i tried doing “fwconsole stop” to stop the server and run again.

Thank you for your reply and i appreciate it.

The transport for the anonymous context is invalid and that’s a bug, which I remember I encountered before.
Do you have Allow Guests to Yes under PJSIP settings?

The port issue is something else.
Please show us sip_general_additional.conf to see what bind port chansip has.

1 Like

How do we know that there is another asterisk is running base on the image that i sent to you? Also, is there a way to stop both asterisk and run one of the asterisk?

Thank You

Okay so i took another screen shots below


Thank You

Im sorry i think i have sent you the wrong part of the img.


i dont know why but i do not see ALLOW GUESTS on my system.

The transport error will go away if you set Allow Guests to No.
It’s in the screenshot you sent above.

This bug was apparently fixed in core v14.0.18.28. Are you below that?
The way it’s right now with the broken transport you can’t receive anonymous calls anyway, so it looks like you don’t need it, Allow guests is rarely needed anyway.

As far as the port conflict, I don’t see why there is one, looks like you might be using TLS.
If that’s a production system and you are down, I would say this is a case for paid support with Sangoma.

1 Like

I really Thank you for your time on replying on my questions. First, i am trying to update the version i have right now and try what you have told me on previous solutions that you gave me.

On my dashboard of FreePBX there is a following error : An unknown port conflict has been detected in PJSIP. Please check and validate your PJSIP Ports to ensure they’re not overlapping.

what does that error mean? and how could I fix it?

My SIP ports are as follows:
Port to Listen On: 5060

Chan Sip
Bind Port: 5160
TLS Bind Port: 5161
how they are overlapping?

On the above post I see that @cynjut said that there is possibility of running two asterisks. when I run the “nmap -sU localhost” , it gave me the same result what @jpark1205 posted. How can I know that there are two asterisk running? and is there a way to stop that?I am sorry guys but I am new to the asterisk and freepbx. Thank you!

1 Like

I also have the same problem right now… i tried to turn off and restart the freepbx/Asterisk, but it did not help… I wish i can help you but i am still stuck on it…

Login to the console and type “ps ax | grep ast”.

That should give you the list of all of the processes running with the word “asterisk” in them. If you see one running, you can kill it using “kill -9 <pid>” where “<pid>” is the Process ID for the process that’s running. Keep cycling through until all of the Asterisk processes are cleared out.

After you figure that out, you need to figure out where the rogue process is coming from. Many manual installs (for example) use “systemd” to start services and some will include asterisk in that list. If you start asterisk that way, then try to start FreePBX “the right way” through fwconsole, the running Asterisk will not die and you end up (as we say in the Admin business) “boned”.