Outgoing calls

Hey,

while testing our new Asterisk server, we added outgoing route and trunk for outgoing calls.

when we tried to test outgoing call we got an error in log:

"… to extension ‘XXXXXXXXX’ rejected because extension not found in context ‘from-did’. "

any help?

This is an error that can only happen on the incoming leg of a call! That leg could be the leg from an extension, but extensions shouldn’t be in the context from-did.

If this really was an outgoing call, you have the outgoing trunk looped back to the originating Asterisk.

1 Like

Hey david,
I talked with our SIP provider for outbound trunk, the login succesed under “Trunks” but outgoing calls still not working.

Also, we setup outbound route but it seems it’s not work.
Can you provide us a little help via Remote Desktop?

Paste the complete Asterisk log for the call at pastebin.freepbx.org and post the last eight hex characters of the URL.

e5fa1a6c

Unless you have users with Israeli IP addresses, these are incoming calls, almost certainly from someone attempting toll fraud by making you pay for calls to premium numbers from which they get revenue. If you do have extensions with Israeli public IP addresses, those extensions have not been configured into the system.

You should disable anoymous calls.

You should configure your firewall to only accept incoming SIP traffic from networks from which you actually expect it, e.g. your service provider.

If possible, you should switch to TLS or TCP.

If that is not possible but using a custom port number is possible, you should change to a port number completely unrelated to 5060.

You should consider enabling fail2bin, which will help rate limit attacks.

Thank you for providing security tips, we know how to secure the system. currently now we are working on Outgoing calls and because of that everything allowed.

Focus the problem please.

I can’t see any outgoing calls, and the error message you provided is the result of an external attack.

It is possible that there is an outgoing call buried in the logs, in which case see:

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs

for how to extract just the one call, or at least indicate the time at which it starts.

Other than one call to extension 100 from a queue, there are no calls in the log with from-internal context. Perhaps your device is misconfigured and is not sending the call to Asterisk. What do you hear? What does the device display show? Can you call from one extension to another?