Outgoing calls won't work Australia NBN VOIP

I hate to bother people on forums like this but I have been googling and fiddling with configs for more than a month. My ISP (Tangerine Telecom) does not support FreePBX, so they are no help. I have a Fixed Wireless NBN connection in Australia. They usually have a VOIP phone attached that can be used on analogue phones connected to a telephony port of the modem/router. I am trying to use FreePBX, I changed to a straight router without telephony. I have set up three extensions, an inbound and an outbound route and registered a trunk. Incoming calls are no problem, they work well. I have yet to get an outgoing call to work. A month or two of fiddling with configurations has meant that I am able to contact the VOIP server (voice.mibroadband.com.au) with out going calls. However, either I immediately trigger a recording saying “If you wish to make a phone call, please hand up and try again” or the phone shows as connected for 20 seconds without any audio and without the target, external phone ringing, before the system eventually just gives up and disconnects. I know this call has made it through to the VOIP server because the voice in the triggered recording has an Australian accent (unlike the FreePBX voices) and the FeePBX logs show the call being answered. I am wondering if my ISPs VOIP server for standard, home consumers just doesn’t support FreePBX. I need help from someone who knows something about the NBN VOIP setup in Australia, or at least can give me some trouble shooting tips. Something else that might help is that if I shutdown FreePBX and connect to my VOIP trunk using a simple SIP softphone then outgoing calls work perfectly, however incoming calls don’t (they ring for a single second but send a busy signal back to the VOIP server which then diverts the call to the backup cellular phone).

In your pjsip trunk, try setting From Domain to the same value you have in SIP Server, and From User to the same value you have in Username.

Also, confirm that the number you are sending is in the same format as they send you on incoming (for example, they may require 02 9319 7455, 61 2 9319 7455 or +61 2 9319 7455).

If you still have trouble, post the settings for the softphone (redact as desired, but make it clear what each parameter means, e.g., use uuuu for username, pppp for password, +61200000000 for phone number, etc.)

Also, at the Asterisk command prompt, type
pjsip set logger on
or
sip set debug on
(if for some reason you used a chan_sip trunk)
make a failing call, paste the Asterisk log for the call at pastebin.com and post the link here.

I already had the from domain and from user set as you asked, worked that one out a couple of weeks ago. That was how I escaped from the American recorded intercepts to the Australian recorded intercepts.

I sent a mobile number because it has 10 digits. The results don’t change if I send an 8 digit landline number or if I add the area code to make it 10 digits.

SIP Phone Settings

server: voice.mibroadband.com.au
user id: 07xxxxxxxx
pasword: pppppppp
port: 5060
transport: UDP
no encryption

Asterisk log link below (from which you will probably see most of what I redacted above):

You will also see my FreePBX is the “distro” version 16.0.40.8, running in a VM with the local IP 192.168.1.117. The extension I used is on a small, linux tablet, though I have two others running on old android phones with the same results. All the extensions can call each other internally without issue and they all receive incoming calls on the trunk,

The log posted has no useful info. The invite from the tablet is 50 lines before the end, so no communication with the trunk is present.

Also, it appears to have been taken from the console, rather than from /var/log/asterisk/full, so timestamps and Asterisk actions are missing.

Please paste a new log.

Sorry, clearly nube issues:

I think I cut off the end, where I hung up, in the last post. Here, attempt number 3:

1. INVITE sip:voice.mibroadband.com.au SIP/2.0


14. Route: <sip:[email protected]:5060>

You appear to have specified an outbound proxy when there is no obvous reason why one would be needed, and you have specified it in the, legacy, strict routing mode, where normally it should be specified as loose routing (\;lr appended). Often provider proxies don’t like the Route header, so it is common to to also require \;hide.

Someone had a similar problem a couple of days ago, and the solution that worked for them was to completely delete the outbound proxy (it seems to have the same address as the final destination).

You are being asked to dial again because you have provided no destination number in the request URI.

Show us the actual trunk settings.

I should have joined this forum weeks ago, you have all been a great help! I appended ;lr to my outbound proxy, per david55’s suggestion, and outbound calls started to work immediately. Now I will have to find something else to make me frustrated and angry for hours on end in the evening. Thanks again to everyone who responded. Is it worth posting the successful settings for someone else in my position later? I was given the impression that I was the only Tangerine customer to ever ask questions about FreePBX, but I guess this may not be true.