Outbound with Didforsale


(Binaryhellstorm) #1

I’ve been having issues with my FreePBX config with DIDforsale. I was able to get their tech support to help with the inbound config (which matches nothing on their web documentation, but works).
I’ve been unable to get them to provide input on the outbound and it’s still hosed. Whenever I try to place a call I get the congestion message which I’m gathering means that the system is unable to actually find a valid outbound trunk and is dumping my call there.

I’ve set up the trunks as per their web documentation as SIP vs PJSIP I’ve eneter my info as their document shows, no dice.
I’ve also tried adding the username and secret into the PEER info, and I’ve also tried using the registration string that they recommend in their documents. At this point not sure what I’m doing wrong here.


#2

DIDFS supports both IP based authentication and SIP accounts. If you have a static (or de facto static) IP address, the former is simpler and more robust. Which are you using? For either, I’d recommend pjsip, unless you are having an unusual problem with it.

If you are getting an “All circuits are busy now” message, it usually means that the trunking provider rejected the call. (If the Outbound Route listed multiple trunks, they were tried in turn and all rejected.)

Note that (for US or Canada calling), DIDFS requires the destination number and caller ID to be 11 digits e.g. 12125551212.

If you still have trouble, at the Asterisk command prompt, type
pjsip set logger on
or
sip set debug on
according to which driver you are using. Make a failing test call, paste the relevant section of the Asterisk log at pastebin.freepbx.org and post the link here.


(Binaryhellstorm) #3

I did enter my IP on their portal as they asked me to do.

I’m find with doing PJSIP instead of SIP but one their site when I try to load the documentation for setting up a PJSIP trunk with them it loads a page that says “Documentation goes here” so I’m flying a bit blind here.

I am indeed getting the all circuits busy message and that was my guess, lol.


(Binaryhellstorm) #4

LOL I stand corrected it was the 1 on the call. I tried that it routed. Thank you so much!


(system) closed #5

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.