Outbound route passing prefix

I have a PRI ZAP channel and very simple dial pattern on my outgoing route: 9|.

Unfortunately, the “9” is being passed to the PRI switch. So, instead of “555-5555” the switch gets “9-555-5555.” For testing purposes I tried 9|NXXXXXX as the dial pattern with the same result.

Any ideas?

I am running PBX in a Flash 1.4 with asterisk using Zaptel. I have applied the FreePBX 2.6 updates.

you are missing information, you need to provide more. If that is the route it is taking, it will not pass the 9. You may have other routes, you may have trunks adding it back in, etc.

I have a single route and a single trunk. It is passing the 9.


I guarantee the issue is ‘user configuration error.’

If you provide details of your configuration as well as maybe a call trace, someone in the forums will likely pipe up and help you isolate what your issue is.

It was a configuration error on my part. I set an outbound dial prefix of “9” on the ZAP trunk. The trace showed the 9 being striped and then being put back on.

Thanks for all your help.