Outbound route cid stopped working


(Efthymios) #1

Following up on below thread.

Outbound calls stopped working after upgrade to Freepbx 14.0.16.4. see logs below for before and after

before (freepbx 14.0.13.23)
https://pastebin.freepbx.org/view/29d9146d

after (freepbx 14.0.16.4)
https://pastebin.freepbx.org/view/44c496c9

calls are made from extension 8000 or 800 respectively to an external number XXXXX025, no CID defined on the extensions nor the ISP SIP Trunk, CID is defined only on outbound route.


(Efthymios) #2

Anybody ? any ideas to try ?


(Itzik) #3

What are the content of your from-internal-custom dialplan? It seems like that breaks it. Your calls are missing the entire internal caller ID builder.

asterisk -x"dialplan show from-internal-custom" | pastebin

…and post the pastebin link


(Efthymios) #4

Hi PitzKey,

(freepbx 14.0.13.23 - working)
https://pastebin.freepbx.org/view/21d9d2c3

(freepbx 14.0.16.4 - not working)
https://pastebin.freepbx.org/view/f6b68a53

As you can see, after the upgrade to 14.016.4 I had to add Set(CALLERID(num)= as a workaround to actually be able to make external calls.

Regards


(Itzik) #5

Remove this line.

exten => _.,n,NoOp( Executing from-internal-custom )

(Efthymios) #6

that’s just a comment for debug purposes, no operation is done


(David55) #7

It’s not doing anything useful, and as it is priority it is making every possible extension number appear valid, and may confuse exception handling as it will match all the special extensions.

The h extension starts at priority 5, so that will not be reached.

I’d actually be more concerned that there is no priority 1 for extension 418. As the first defined priority is 3, the above mentioned line will accept it, but then it will fall off the end of the dialplan at priority 2, which may not result in the intended rejection cause.

418 will sort of work in your first example, as it starts at 2, and the _. line will get it there. h is still broken, as that starts at 3, so execution will end at 2.

Your h extension wouldn’t do anything useful, anyway, as the call is already hung-up.


(Efthymios) #8

You are right, it actually works without it ! Thanks !

the priorities just got messed up with all the testing and commenting of lines ;). I’ll fix that.
So, why it doesn’t mess up the dialplan with 14.0.13 but it makes such a difference with 14.0.16 ?
Is there a better way to insert a comment during operations for debugging ?


(Lorne Gaetz) #9

We need more info for a proper recommendation but you can prob use a dialplan hook:


(Efthymios) #10

The dialplan hook seems to achieve the same result, but also seems to be over and above what i’m trying to achieve. I’ll read up on it and see how to implement it for my purpose.
Still there is the question why it worked on 14.0.13 (same noop command) but doesn’t work on 14.0.16.


(Itzik) #11

The question is not why it is not working in .16. Rather, the question is, how come it was working in .13 considering that you removed a crucial part of the FreePBX dialplan…

And to be honest, I am pretty confident that there are definitely stuff that weren’t working correctly on .13.


(Efthymios) #12

Agreed… still external calls were working in .13, strangely enough.

I’ll revise my dialplans and get rid of this issue.
Thanks for your help


(system) closed #13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.