Outbound dtmf broken in

I updated from 2.7 to 2.8 now outbond dtmf overdial is broken. my system is a pbx with iax trunks to an asterisk server to a sip provider. i can not make a call and then send dtmf digits like to a pager or an ivr system. everything worked fine until last weekend when i did an upgrade. the upgrade went fine with no problems. pbx functions like expected just no outbond dtmf. I tested another 2.7 system connected to the same server and sip provider and dtmf worked so the problem lies in 2.8.

just did a test by calling a copper land line and listening to the dtmf tones. it seems that in 2.8 we are sending inband and out of band at the same time. i hear 2 bursts of dtmf with each button push. 2.7 build only sends one burst of dtmf. bug in 2.8?

Did you upgrade Asterisk as well? What version of Asterisk are you using?

I did not upgrade asterisk i am on 1.2.24

Actually FreePBX does not send any data, Asterisk does. FreePBX populates config files that Asterisk use.

Check in FreePBX Extensions that dtmfmode is set to what you want, default is rfc2833.

Check your Trunk settings for any dtmfmode settings.

Finally, check your phone device for any DTMF setting. Grandstream phones can have many DTMF enabled and that causes multiple DTMF to be sent.

my phones are all aastra units. we have 2.7 running at our office and it works fine calling the same ivr same sip trunks upstream. i have tried every combination in the phones and dtmf mode in the 2.8 box. no joy. i will reload to 2.7 this weekend and see what happens. trunks were set to rfc2833 changing to inband did not make a difference. i am now hearing a short burst of dtmf when calling a landline.