Outbound CID shows extension, not main number

I saw this article but it did not have any answers for me:

Here is the setup:

AsteriskNOW w/ FreePBX
Using Comcast SIP services

All outbound calls to ANY line, cell or land, results in the CID being the extension, not the main number.

I have the Outbound CID set as <main number> in all the extensions and the trunk settings.

What am I missing?

Sounds like you have ‘intra-company’ enabled on your outbound route(s).

Something new to add:

This apparently happens on the Cisco 7960 phones we are using.

If I call outbound using one of the Polycom IP 5000s, the CID is correct.


Yep, it was the intra-company switch on the trunk!


1 Like