Outbound CID problems (when redirecting inbound calls)

I’m having a problem where incoming calls that are then routed externally keep their original CIDs. This is a problem since our provider (correctly IMHO) disallows those calls.

Originally the setup info from our provider hardcoded the outgoing CID using the “fromuser” flag on the trunk. After being tasked with showing whichever of our “local” office numbers was closest to the dialled area code, I removed that trunk setting and added a route CID to a few outbound routes with various dial patterns. (Each local number is registered with our provider so they’ll accept any of them).

Unfortunately, while this seemed to be working great I’ve since discovered that it broke DISA and cell-phone extensions, due to the problem in paragraph 1. The DISA module has a “Caller ID” field that I can set (losing the most-local-CID feature, but at least outbound dialling works), but I can’t figure out how to get cell-phone extensions (which I’ve set up as custom technology, with a “dial” entry of “Local/[email protected]”) to work.

In my earlier thread about DISA it was suggested that I use the “Custom Context” module, but I’m reluctant to do so yet as I don’t want to complicate what was intended to be a simple system by working around things I shouldn’t be.

Thanks in advance

Maybe the easiest way is maybe to get a SIP account that allows arbitrary CID (most here in the US do) for your outbound calls, get a per minute plan and the cost is very small.

I hadn’t thought of that option; I believe our provider will allow this if we sign some paperwork, so I’ll look in to that, thanks. I’m not sure if management will approve that solution however, since they would never know if a call was coming to them directly, or routed through their office “extension”.