Outbound CID Attended transfer set to Extension


when i transfer an external call to an external number the from header contains only the extension number.
Neither an overwrite from the trunk config nor any DID setting on the extension works.
At a normal external dial all works fine.

An overwrite in [macro-dialout-trunk-predial-hook] does not work too.
Chan type is pj_sip.

Is this a bug?


Freepbx Version is
Core Version is

I’m guessing that you were bitten by this bug:

I suspect that you didn’t do it correctly. Predial hook is after the bug so should have worked.

Were you doing this via DTMF or another unusual way? On a normal IP phone (or softphone, SIP app, etc.) when you press the Tran key, the current call is placed on hold and the phone makes a new call. Asterisk isn’t even aware that this is a transfer until you press a key or hang up to complete it (which tells Asterisk to bridge the calls together). So it’s hard to imagine how this bug could have manifested itself on a ‘normal’ transfer.


i’ve tried different things in [macro-dialout-trunk-predial-hook] eg:

exten => s,n,Set(CALLERID(all)=)
exten => s,n,MacroExit

The curious thing is that it sometime work for exactly one call after the reload, but not every time.
The singnaling is via DTMF, via the default asterisk feature code.

I’m using as softphone FOP2, but in the UCP it does not work either.
When i call from internal to external and then transferring this call all works fine the whole number will be shown not only the extension.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.