Outbound Calls Working but Inbound Says Nothing

Hey everyone,
I have the problem that I haven’t had any inbound calls since an update, but outbound works.
I don’t know if my provider (Deutsche Telekom ALL IP) changed something.
Have anyone a clue or an similar problem?

FreePBX 16 on arm Base (Turris Omnia with LXC on Debian 11)

Yes, Deutsche Telekom disabled a couple of older things a few weeks ago. You need to post your configuration, or we can only guess.

If outbound calls work, then the Telekoms may not know how to contact you. pjsip show registrations will show you the current status. If the registrations are OK, the Telecomedians may not like you, because you have registered to a different proxy than you are using for the current call. That’s a known feature/bug/pain in the neck and it is related to the way the Telekom DNS resolution for tel.t-online.de works. You could generate a SIP trace and in that case you’d see a couple of “verboten” (forbidden) replies.

As I said, without knowing the setup and the configuration, it is just guessing.

Hi jgttgns,
thx for your reply. The Registration is ok, the dns resolution for “tel..t-online..de” works aswell so. If i provide my sipclient (mricosip) the user a PW for a single number it work but i must enable Ip Rewriting because i have a second nat…
In Addition to that my Outbound voice dosent work anymore :frowning: “Zurzeit sind alle Verbindungen schon belegt…”

Are you saying that if you let your softphone directly register to an ALL IP account, things work? To what does your tel.t-online.de resolve? Do longer phone calls (> 60 minutes) work with your softphone?

As I said before, without a configuration and a SIP trace only crystal ball glazing will solve your problem. As far as the Telekom changes are concerned, there was nothing tricky and the connections are rock solid.

Hi gittens, first of all what do you need from me on information, I am relativ new to FreePBX… i hope you can provide me instructions how can make a sip trace or to gather logs from Asterisks or FreePBX.

To answer you question yes softphone(microSip) directly register to an ALL IP account works fine :slight_smile: but not on my FreePBX :frowning:



1 Like

Compare the pcap traces…

Hi Everyone,
thank you for you help. After a Discussion with my Chef we decided to move from the LXC Container in our Router to an Virtual Machine with the offical FreePBX iso and now it works… i dont know what is broken in my LXC container but now it works on the VM.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.