Outbound calls say all circuits busy and all calls going direct to voicemail

PBX Version
PBX Distro 12.7.8-2203.sng7
Astrisk Version 16.30.0

I’m not all that versatile with SIP and this PBX system. I’m looking through the forum for some assistance with similar issues, and it appears the Wiki is out of date with the version that I have. So please, forum, take pity and assist.

The symptoms:

  1. Inbound calls ring for the caller for about 30 seconds and drop to voicemail.
  2. During the call, the phone doesn’t ring at all.
  3. Outbound calls are hearing a report that all circuits are busy.

I have a putty connection and tracked one call and captured the log but I don’t know how useful it will be.I’d appreciate any assistance you can provide.

Logs are essential.

32 seconds is the normal time to abandoned a SIP call because there is no response from the called user agent. You need to find out whether the call is getting lost inbound, or the response is getting lost outbound.

1 Like

I understand logs are the only way to determine cause. I’m tring to find instructions on how to look at the logs that match the web interface I’m looking at right now.

OK! I got the logs and here’s the log from them making a failed outbound call. I see where they are hearing the outbound circuits busy message, but I’m not seeing why. This log is me calling the user, which went through and them attempting to call me right back at the same number:

> Blockquote


The call was properly associated with the ‘SIPStation-Out’ Outbound Route, but no trunk access was attempted. Please confirm:

  1. Trunk is listed in “Trunk Sequence for Matched Routes” in the Outbound Route.
  2. Trunk is Enabled in settings for trunk.
  3. Trunk is Reachable (shows Available in Reports → Asterisk Info → Peers.
1 Like

Thanks for the reply.

It looks like trunk sequence for matched routes is blank. There are two options there, but neither are chosen.
They are both enabled.
Status is ONLINE for both.

I set the two trunks in the outbound route and will try again.

That didn’t work. Here’s the change I made:

I went to Connectivity > outbound routes > SIPStation-Out > Edit
For “Trunk Sequence for Matched Routes” I set fbx-1-97luBY… as one and fbx-2-97luBY… as two (paraphrased the actual name of the trunks there.)
I went to Connectivity > Trunks and saw them both as enabled
I went to Reports > Asterisk Info > and saw they were both ONLINE

The call still failed.


The settings change appeared to not take effect. Did you Submit and Apply Config? Were any errors shown on these steps?

There have been some sporadic reports of Apply Config not working, that have not yet been resolved. From a root shell prompt try
fwconsole restart
and retest. If no luck, look at the Outbound Route again and see whether your changes are still present.


That was the issue. The outbound calls are working again. Thank you so much for the assistance!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.