Outbound Calls Are not working

I get the Call cannot be completed as dialed

Trunk settings

type=friend
qualify=yes
secret=xxxxxxxx
host=xxxxxxxxxx
insecure=invite
context=from-pstn-toheader
trustrpid=yes
dtmfmode=rfc2833
port=5060
canreinvite=no
disallow=all
allow=ulaw
disallowed_methods=UPDATE

LOGS
https://drive.google.com/file/d/1q5b6kjOgcQbeMGttLbNHK_eL79K4_Qn9/view?usp=sharing

Any help would be appreciated

It appears that the call was completed OK by the PBX, but the provider connected to the GXW rejected the call. I suspect that the number was incorrectly formatted, but I’m not familiar with dialing rules in Saint Lucia so can’t say for sure.

The caller apparently dialed 7151770, but the Outbound Route rewrote it to 7587151770, which is what was sent on the trunk. Possibly, for a “local” call, the provider expects 7151770 or maybe 17587151770, but rejects 7587151770. If that’s your issue, fix the Outbound Route prepend.

If not, confirm that 7151770 is what the caller actually dialed, and (by temporarily connecting an analog phone to the line) that 7587151770 is accepted by the provider. If so, possibly the Dial Plan in the GXW did additional rewriting of the number to something the provider does not accept. You can use its syslog feature to view what digits got sent on the trunk.

The dial plan is just fine and also the format is fine, that is what my provider accepts(758 is our area code). I am really certain about this because I have 3 other systems with this exact dial plans. Which is why its puzzling as to why I have this issue.

Also I had the basic 7&10 digit dial plan before and encountered the same issue.
(NXXXXXX)
(NXXNXXXXXX)

any possibility of engaging your provider’s support to verify?

i recently had a provider switch to ONLY accepting e.164 formatted numbers (+1npanxxxxxx for the north American region)

I could give that a try but if they did wouldn’t that change affect my other 3 systems?

interesting log item:

7041 [2021-11-08 20:05:24] VERBOSE[12118][C-00000014] pbx.c: Executing
[[email protected]:7] ExecIf("SIP/106-00000023",
"1?Set(TRUNKCIDOVERRIDE=<7584581370>)") in new stack

any chance your other trunks have a leading 1 in the callerID Override?

No they do not.
I figured out what happened I now need to configure properly.
I have two lines connected to my Grandstream gateway. The provider has restrictions set to not allow cellphone calls on one and the other is not allowed to make landline calls. The issue is I only have one trunk for both lines and its set as round robin, so when I try making cellphone calls the first line which it chooses is the wrong line. I guess I will have to create separate trunks and outbound routes. Rookie mistake for not confirming this before even going ahead :sweat_smile:

thats… super gross.
glad you figured it out.

can you not set it up as two different trunks, and NOT do round robin? it sounds like you are setting yourself up for failure if legit 50% of your calls will fail.

l:joy:
Strangely enough I created the two trunks but it still happens for some reason.
I deliberately removed the trunk with cellphone restriction from the outbound route but I still, for some reason still get the “Call cannot be completed as dialed” message.

If i disconnect the pots line from the gateway, calls go through just fine.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.