Outbound Caller ID in SIP Name Field

Hello,
I’m imagining that there isn’t a simple fix for this but here it goes:
FreePBX 12
Asterisk 11.19.0

When I make an outbound call, asterisk is providing the name of the person I am calling back to my phone. This is great, I love it. When I call an extension on my system I get the name of the person at that extension.

First question: sometimes i get FirstName LastName and sometimes I get FirstName LastName(Presence)
is there a way to disable the presence indicator?

My real problem:
When I make an outbound call, asterisk obviously doesn’t know the name of the person I am calling. That’s okay. Instead it provides my outbound CID in the name field. ex: CID:2165555555
I need to turn this off.

This wouldn’t bother me if the phone wasn’t logging my call history, when I search through the call history list it’s just a huge list of CID:2165555555 because the phone thinks that is the name of the person I was calling. If Asterisk doesn’t provide anything in the name field it, the phone will just show the number that I dialed instead, as is expected.

The Asterisk log shows this:
[2016-01-06 19:47:50] VERBOSE[30794][C-0000004c] pbx.c: – Executing [[email protected]:20] ExecIf(“SIP/7001-00000051”, “1?Set(CONNECTEDLINE(name,i)=CID:2165555555)”) in new stack

Anyway to turn this off?
Thanks,
Addison

Any ideas if this is a “feature” that I could disable in Asterisk?

Advanced settings:

“Display Presence State of Callee”

Perfect, Thank you! I knew it had to be there somewhere.
The other one that I really needed turned off was there as well “Display CallerID on Calling Phone”

Thank you,
Addison