Outbound call "The number you have dialed is not in service"

Hello, can somebody help me read the log and figure it out what’s wrong? I have a new installation on a twilio-justcall trunk and I get the number you have dialed is not in service all the time.
ports are open, ALG is on on the router, I am getting inbound calls just fine.

I tried to talk to twilio and justcall but they only sent me 2 generics guides (which I followed) and I couldn’t get anything else from them.

I have tried pjsip and sip trunks same results.


Freepbx 15 / Asterisk 16
log outbound call

It appears that you are sending 250 as the caller ID, which Twilio is rejecting.

Confirm that Outbound CID for the extension is correctly formatted, that you are not overriding the caller ID in the Outbound Route or the Trunk, and that the Trunk is configured to send caller ID in the header (From, P-Asserted-Identity or Remote-Party-ID) that Twilio is expecting.

Twilio may reject caller ID that does not match a number on your account or that you have verified with them.

If you still have trouble, at the Asterisk command prompt type
pjsip set logger on
make a failing call and paste a new log.

Thanks Stewart for your reply, I’ve try to change those settings (from P-Asserted-Identity or remote-Party-ID from the extension in FreePBX and from the trunk setting but no luck so far, same results.

I’ve set the logger on as instructed, please if you can take a look

set pjsip logger on


Just if somebody else find this useful, to fix this problem in my case we had to set CallerID in the Outbound route as the trunk username

thanks Stewart you were right on track

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.