Outbound call shows own number on outbound phone instead of dialed number


I’ve discovered that on outbound calls from my FreePBX System, it shows the own number with “CID:” prefixed.

in extensions_additional.conf, I’ve found this:


exten => s,n,ExecIf($["${DB(AMPUSER/${AMPUSER}/cidname)}" != “”]?Set(CONNECTEDLINE(num,i)=${DIAL_NUMBER}))
exten => s,n,ExecIf($["${DB(AMPUSER/${AMPUSER}/cidname)}" != “”]?Set(CONNECTEDLINE(name,i)=CID:${CALLERID(number)}))

If I comment out both lines, I have the wanted behaviour - on outbound calls it shows the dialed number, however it’s of course not intended to manipulate config files there as it’s overwritten anyway when regenerating config.

So where can I change this in the webUI

Just to clearify. You want the number used for the CLID to be the number you dialed. Example, if you call my cell (e.g. 309-555-1212) from your phone, you want the number that shows up on my phone for the CLID to be my own number?

1 Like

No, I’m lust looking at my phone (the outbound dialing phone). Currently, it shows my own number (prefixed with “CID:”) after remote has answered my call. It doesn’t make any sense to show the own number during a call. Normally you want to see the number of the person you’re talking to.

Obviously the command “Set(CONNECTEDLINE(name,i)=CID:${CALLERID(number)}))” which is executed on the outbound dialing phone is responsible for that. It is in context macro-dialout-trunk

I’ve found this in Advanced Settings:

Display CallerID on Calling Phone? and Display Dialed Number on Calling Phone?
If I disable it (on by default), I have the wanted behaviour.

IMHO it’s working wrong because if both settings are on, it displays my OWN number on the calling phone instead of the dialed number. If I disable only the first option, the displayed number shows (probably as intended) after trunk dial rule manipulation, in my case it suppresses the first ‘0’ in display to dial an external number. But showing the OWN number on the calling phone is totally wrong, I believe.

good day dear alan,

i have such trouble.

i want to call some numbers and have their self numbers in their phones.

i need something like set outbound CLI = Dilaled number.

please advise,

Not sure how much more explicit the answer can be. Is there some other question you’re not asking?

1 Like