Outbound call redirected to extension? weird

I have an Openvox board connected to a handset.
I then have a VOIP connection for the outbound.
I do this so that my handset for the office (connected as line 2) will ring throughout the house.

I ran a yum update on my machine and have now (mostly) hosed system.
I can receive calls from external sources.
I can call from a softphone extension to the analog phone.

I can call out from neither the softphone nor the analog handset.

Here is the (edited) cli from a call from the analog handset:

Verbosity is at least 26
– Starting simple switch on ‘DAHDI/2-1’
– Executing [[email protected]:1] NoOp(“DAHDI/2-1”, “Catch-All DID Match - Found 91NNNYYYZZZZ - You probably want a DID for this.”) in new stack
– Executing [[email protected]:2] Goto(“DAHDI/2-1”, “ext-did,s,1”) in new stack
– Goto (ext-did,s,1)
– Executing [[email protected]:1] Set(“DAHDI/2-1”, “__FROM_DID=s”) in new stack
– Executing [[email protected]:2] Gosub(“DAHDI/2-1”, “app-blacklist-check,s,1()”) in new stack
– Executing [[email protected]:1] GotoIf(“DAHDI/2-1”, “0?blacklisted”) in new stack
– Executing [[email protected]:2] Set(“DAHDI/2-1”, “CALLED_BLACKLIST=1”) in new stack
– Executing [[email protected]:3] Return(“DAHDI/2-1”, “”) in new stack
– Executing [[email protected]:3] Set(“DAHDI/2-1”, “CDR(did)=s”) in new stack

It seems to be blowing up on the second line. The extension is defined as ‘from-internal’, by the way.

The softphone cli output reads:

== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
== Using UDPTL TOS bits 184
== Using UDPTL CoS mark 5
– Executing [[email protected]:1] ResetCDR(“SIP/200-0000000f”, “”) in new stack
– Executing [[email protected]:2] NoCDR(“SIP/200-0000000f”, “”) in new stack
– Executing [[email protected]:3] Progress(“SIP/200-0000000f”, “”) in new stack
– Executing [[email protected]:4] Wait(“SIP/200-0000000f”, “1”) in new stack
– Executing [[email protected]:5] Progress(“SIP/200-0000000f”, “”) in new stack
– Executing [[email protected]:6] Playback(“SIP/200-0000000f”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack

Any thoughts on this would be appreciated; clearly a file somewhere has a bad parameter since incoming calls work just fine.

Regards,

Andrew

looks like your chan_dadhi.conf got screwed up and if it’s not properly including your chan_dahdi_additional.conf file that FreePBX generates then none of your configuration will be pulled in.

Phillippe,

Thanks for the reply,

I checked the chan_dahdi.conf file and it has the appropriate lines per the Openvox installation guide.

dahdi show channels shows:
PhoneSystem*CLI> dahdi show channels
Chan Extension Context Language MOH Interpret Blocked State
pseudo default default In Service
1 default default In Service
2 from-pstn en default In Service

which appears to be correct (although shouldin’t that say from-internal?).

Is there a ‘next’ I should check? I have run dahdi_genconf and checked the files a few times.

Thanks again.

Regards,

Andrew

I answered your question above.

If you would prefer to believe Openvox you may want to try their forum for help.

Since you came to the FreePBX forum I think it’s generally understood you are looking for FreePBX help… If Openvox disagrees with what I said, then they don’t understand what FreePBX needs…

I’m laughing at my own ignorance. It seems clear that I don’t understand your answer. This is my issue, not yours.

What I meant to say or make clear, is that the Openvox install requires that a line be added to the chan_dahdi.conf file. That line is:

#include dahdi-channels.conf

and is included in my file. Therefore the file may still be wrong, but I’ve exhausted my ability to ferret out what might be wrong about it.

The full version of the file (which is short) is:

; include dahdi extensions defined in FreePBX
#include dahdi-channels.conf
#include chan_dahdi_additional.conf

; XTDM20B Port #1,2 plugged into PSTN
;AMPLABEL:Channel %c - Button %n
context=from-pstn
signalling=fxs_ks
faxdetect=incoming
usecallerid=yes
echocancel=yes
echocancelwhenbridged=no
echotraining=800
group=0
channel=1-2

the file chan_dahdi_additional.conf reads:

;--------------------------------------------------------------------------------;
; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
; this file must be done via the web gui. There are alternative files to make ;
; custom modifications, details at: http://freepbx.org/configuration_files ;
;--------------------------------------------------------------------------------;
;

;;;;;;[100]
signalling=fxo_ks
pickupgroup=
[email protected]
immediate=no
echotraining=800
echocancelwhenbridged=no
echocancel=yes
context=from-internal
callprogress=no
callgroup=
callerid=100 <100>
busydetect=no
busycount=7
accountcode=
channel=>2

Since the Openvox forum won’t even allow me to correctly register, going in that direction isn’t even an option for me.

I appreciate the help, I’m just a little on the slow side and far from being considered even a novice in understanding how to interpret what might be incorrect in these files. A google search shed no light on the matter.

Thanks again,

Andrew