Outbound Call Recordings break after Attended Transfer


I am using Asterisk 13.14.0 with FreePBX, running on Centos 6.7. I have tried every combination of options and versions to get this to work and it still seems broken.

When an outbound call is initiated by a local extension, and then goes through an attended transfer, the recordings stop as soon as the call is transferred. I usually have one recording for the first part of the call (out-xxxxxxxxxx-xxx-xxxxxxxx-xxxxxx-xxxxxxxxxx.xx.wav) and a recording for the attended part (conversation between two extensions; internal-xxx-xxx-xxxxxxxx-xxxxxx-xxxxxxxxxx.xx.wav).

I have tried setting outbound route recording options to Force and extensions to Yes…setting both extensions and outbound routes to Force…using the Call Recording module to Force recordings directly on the trunk…I have also tried setting the outbound routes to yes and the extensions to Force. Nothing seems to work; in every single situation, the recordings stop as soon as the attended transfer is done.

I have tried using Asterisk 13.13.1, 13.13-cert1, 13.14.0…nothing seems to work.

Is this a bug or is there something I don’t understand about Recordings? (By the way, I have read the “Limitations when a Recording is Started by an Outbound Route”, which is why I upgraded to Asterisk 13.x.x.)

Thank you for your time.

Sounds like something the developers need to look at. I’m not sure if it’s a bug or a side-effect of a feature, but it sounds like something isn’t working.

Have you submitted an Issues Ticket?

I opened a Bug Report but I will send this to Issues Ticket as well. Thanks for the recommendation.

Anyone have any ideas? Anyone experience this issue before?

Your new ticket is probably a duplicate of this one:

Can you confirm it’s the same issue?


First of all thank you for the quick reply. I have the same symptoms as the ones described in the issue you posted (Third leg of the call missing). However, my problems are only when the call is initiated through an outbound route; I have no problems with inbound call recordings.


I am able to get recordings to work using the *2 code to perform attended transfer instead of using Transfer button on phone. The problem therefore seems to be with what the phone sends to the server.

However, I was able to replicate the issue using many different models of Yealink (T22p, T28p, T40p, T48s), Polycom (Soundpoint 331, Soundpoint 550, VVX 300, VVX 400) and Aastra/Mitel (6869i, 6737i). No matter the brand/model, the issue persists.

Is anyone able to explain why it can work using the *2 code but not with a phone Transfer Button?

Anyone ever had problems with recording of outbound transferred calls?

We had a discussion about this a while ago. There are other issues that pop up with calls dropping after 15 minutes and other things.

@lgaetz I think Lorne explained it last time - basically, instead of transferring the call under PBX control, the phone “takes the initiative” and sends to call to the other phones. Since this is a new call, there is not “recording” check and the conversation proceeds without any further interaction from the phone.

I think.

It might have be @jfinstrom that explained it. Note that it was a very similar operation (maybe not transfers, might have be ‘3-way’ calling.

This makes a lot of sense. I appreciate the input. For now I got the client to reluctantly comply with using *2. If I find a better solution I will definitely be posting it.

With many phones, you can “override” the “standard” buttons with your own dial codes. I don’t think you ever specified what phone you are using, so no one is going to be able to make a suggestion, but check with the manufacturer and see if there’s a setting that changes the “standard” transfer code to something we can use.

For some of our other clients using Polycom phones, this will definitely not be a problem. However, this particular client uses Yealink T22p phones with a physical DSS Transfer key that cannot seemingly be overwritten

Hopefully, someone that knows someone at Yealink can get you an answer. It might be something worth talking to Yealink about. Setting up a seconday “Xfer-Rec” button on the phone that dials the code for you might work too.

If you create a new button, a little bit of electrician’s tape might solve the “two buttons” problem. It worked for my wife’s Oil Light (for a while).

Thank for the advice ! I will definitely look into getting in contact with someone at Yealink.

Client seems reluctant to add tape to their phones, but I can no doubt convince them that their recordings are more important than phone aesthetics

You could also go with a Dymo Label that says “Violate HIPAA” instead of “Xfer-NoRec”. Maybe that will help them understand?