OSS EPM + Polycom SoundPoint Contacts


We use Polycom SoundPoint range of phones and I would like to get the contacts directories working properly.

Using HTTP to serve the configs in OSS Endpoint Manager - the symptoms I have is that the phone doesn’t get it’s default directory (00000000-contacts.xml), and the phones will also PUT a personal directory ([mac_address]-contacts.xml) up on the server but it’s empty.

So, checking out the httpd access logs, I can see the phone asking for the default directory but it get’s a 404 error. The problem with the personal directory I think is similar - the logs show a 200 OK response when the phone PUT’s a file up but seeing as though the file is empty I’m assuming it can’t actually write into the file.

Having a look at the path that the phone is requesting the directory from - /provisioning/contacts/ and then comparing that to DocRoot, that directory doesn’t actually exist. On the local filesystem there is just /var/www/html/provisioning/. I know there is some fanciness going on with p.php, which must actually go grab the right file and serve it to the phone but anything outside of the root directory of where the configs are stored doesn’t work (so, contacts, logs, overrides).

I tried adding a symlink under /var/www/html/provisioning/contacts and pointed that to where the contacts files live on the local filesystem (in my case, /config/contacts/) - but still, even though locally I could browse to a file at /var/www/html/provisioning/contacts/00000000-contacts.xml, if I tried to browse there via the web to http://[freepbx]/provisioning/contacts/00000000-contacts.xml I would still get a 404 not found.

I also tried making an apache alias as well but that was no different.

On a side note, it’s not just contacts but also logs. The phones will PUT up their app and boot logs but the files are empty on the server - same issue, can do the PUT but can’t actually write.

Maybe it’s just a permissions thing, and I suck at unix permissions and etc or maybe it’s something more complicated.

Has anyone had luck with getting contacts and the additional directories working with the Polycom configs in OSS EPM?

Don’t care that the files don’t really have anything generated in them from EPM - will worry about that later - I just want the files to be properly served out to the phones.

Thanks in advance.

Didn’t mention that I’ve tried to keep everything as roughly 770 asterisk:asterisk

Pretty sure https is running as asterisk user, and afaik 770 permission on dir and files means that the asterisk user and group should have full access to everything - thus, httpd should be able to serve everything up.

Restarted httpd between each change I made as well.

I suppose no one else has run into this problem.

I had a sysadmin look into it, because I suck at PHP. Seems that the p.php script that offers configuration files to the phones is broken and will always return a 404 when the phone asks for /provisioning/contacts/-directory.xml.

Something about that p.php looks at a DB for a list of configuration files to serve up when a phone makes a request. The DB entry for the directory doesn’t exist.

I assume that this probably won’t get fixed though, especially not in v2.11 - but, is there any hope in v13? Is OSS EPM even maintained anymore? Is there any doco (apart from the readme’s in github)? Will Provisioner.net ever come back?

We will be implementing some “manual hacks” to get this working for one particular customer - but it is just that, very manual, so it’s not really a solution.

If there’s anyone in these forums that develops for OSS EPM or contributes, I am happy to share the information I have if it means some hope of a proper solution for v13? I would make commits to git however I am far from programming-savvy…

Since you’re working with the OSS version of EPM, it’s kind of up to you to fix it, or at least get a patch ready for whoever is going to fix it.