OSS Endpoint

This is more of a concepts question I think.

Let me start by saying I’ve used Asterisk with the FreePBX interface for a few years now, but only doing call plans and IVRs on a box that someone else set up. Now I’m trying to set up my own box. I installed the FreePBX Distro and am getting stuck on the OSS Endpoint. I’ve got it installed, I can scan for my devices and find them, but I’m not getting how they get configured. The main question here is what is required to provision my phones?

I haven’t set anything up other than what’s default in the distro (and the fist steps doc). Which means I haven’t played with tftp or dhcp. I’m assuming they are required from previous knowledge, but can’t find any documentation to help me through any of it.

This is kind of moving the topic, but now I can’t figure out why my dhcp server won’t start.

I’ve tried service dhcpd start and /sbin/service dhcpd start

My /etc/dhcpd.conf file looks like this:

ddns-update-style interim;

option boot-server code 66 = string;

subnet netmask {
        option subnet-mask;
        option boot-server "ftp://gjm:[email protected]";
        option time-offset -18000;
        option ntp-servers;
        option domain-name-servers;
        option domain-name "voip.lan";
        option routers;

Any thoughts? Even if the options are wrong, any thoughts on why the service won’t start? I’ve tried to start it with only the basics as well.

If you can see your phones then they will have IP addresses already which they probably got from a DHCP server somewhere. TFTP should be setup by default to point to the /tftpboot directory on the machine. Have you been into OSS End Point Manager to enable the manufacturer and phone models that you have? Which phones do you have by the way. EPM supports large numbers of handsets but not all of them.

I’ve got a Polycom IP 550 that I’m trying to connect at the moment. I’ve been into the manager and enabled that brand and category of phone.

From what I understand, the systems that I maintain send out ftp information along with the dhcp. So maybe I’m over thinking this, but how would the phones get access to the phone server (yes, I know the server knows the phone MAC, is that enough?). Does anything need to be configured on the phones themselves?

I think what you are missing is that the DHCP server has to hand out the IP address of the phone server in DHCP Option 66 (Boot Server).

The phones will then pull the mac.cfg file via tftp protocol (not ftp as you have indicated).

Most low end routers don’t supporting setting DHCP options. I usually use the DHCP server in CentOS.

It won’t start because the config is wrong. You can see the errors in /var/log/messages with a quick tail.

Below is my working DHCPD.conf

Keep in mind it has a few extra’s like the bootfile name for a DECT access point.

ddns-update-style interim;
ignore client-updates;
option bootfile-name "omm_ffsip.tftp";
option openmob-serverip code 43 = string;
option openmob-name code 224 = text;

subnet netmask {

  option routers        ;
  option subnet-mask    ;
  option nis-domain               "asterisk.local";
  option domain-name              "asterisk.local";
  option domain-name-servers;
  option time-offset              -18000; # Eastern Standard Time
  option ntp-servers    ;
  option tftp-server-name         "";
  range dynamic-bootp;
  default-lease-time 43200;
  max-lease-time 86400;

host omm {
  hardware ethernet 00:30:42:0D:F2:5E;
     option openmob-serverip         0a:04:c0:a8:2:6;
     option openmob-name             "OpenMobility";

I’ve tried your dhcpd.conf file and I still get a failed.

Here’s the error in the messages file
dhcpd: Internet Systems Consortium DHCP Server 4.1.1-P1
dhcpd: Copyright 2004-2010 Internet Systems Consortium.
dhcpd: All rights reserved.
dhcpd: For info, please visit https://www.isc.org/software/dhcp/
dhcpd: Not searching LDAP since ldap-server, ldap-port and ldap-base-dn were not s$
dhcpd: Wrote 0 leases to leases file.
dhcpd: No subnet declaration for eth0 (
dhcpd: ** Ignoring requests on eth0. If this is not what
dhcpd: you want, please write a subnet declaration
dhcpd: in your dhcpd.conf file for the network segment
dhcpd: to which interface eth0 is attached. **
dhcpd: Not configured to listen on any interfaces!
I’ve got it assigned to the interface in the DHCPDARGS file as well. I’ve confirmed my subnetting is correct.


What is the IP address and subnet mask on eth0? /

I just did a new distro last night, looks like the file has moved to /etc/dhcpd/dhcpd.conf

You are loading the sample file.

You can verfiy this by looking at the init script in /etc/init.d

Thanks for that. The correct path, just for reference, is /etc/dhcp/dhcpd.conf in my config.

Still having some boot server connection issues, but I’ll troubleshoot that further and post back.

Thank you so much for all your help.

Looks like the 2 things I had wrong was the location of my dhcpd.conf file and the option inside of it.

My dhcpd.conf file has the following in the global area:

option boot-server code 66 = string;

And the following inside the subnet declaration:

option boot-server "tftp://";

(where is my freepbx distro). Without the tftp:// it wasn’t working with my Polycom ip550 (the only one I’m testing with right now).

Thanks again to SkykingOH for your help.