OSS Endpoint Manager installed but no menus created

Hello! I am using FreePBX 13.0.143 and I’ve installed OSS Endpoint Manager 13.0.6.7. Yet I have no menu entries under Connectivity.
I first disabled “Phone Apps” and “REST API”, then uninstalled “Endpoint Manager”. I was able to install “OSS End Point Manager” and got no errors on the install. Yet after running the “Apply Config” I see no menus. I can even use the link: http://x.x.x.x/admin/config.php?display=epm_advanced and I get the response “Module Not Found”. It does show up in Module Admin as being Enabled.
Can anyone point me in the right direction? I’d really appreciate the help… :smile:

did you install any packages?

Not other than OSS End Point Manager.

Just checked with my last successful install of FreePBX Distro - it was FreePBX 13.0.101 using this same version of OSS End Point Manager (13.0.6.7). I didn’t have any problem with installing (and using) OSS End Point Manager with that version of FreePBX. So it appears to me that something between FreePBX 13.0.101 and 13.0.143 “broke” the install of OSS End Point Manager. Is there any way to downgrade FreePBX versions? Or does anyone have any idea of what happened to the install? Thanks again!

you can down grade most modules using the admin module
in the module admin click on "check online"
then expand the item and you should see “previous” and from there you can select what you want to roll back too

The problem is that I’m not even sure what module I’d have to downgrade to get the OSS End Point Manager to install. I just know that the same version of End Point Manager installed with a pretty recent version of FreePBX. Any ideas on what I could try to get the OSS End Point Manager to install and be accessible in the FreePBX admin menu?

i guess short of removing the oss epm and then reinstalling it i have no additional suggestions.

the small price of the paid version of the epm is well worth it. it behaves differently then the oss epm but in general gives you better control over the configs that get built. if you are a tinkerer then the oss epm is your ticket because you can roll your own if you wish.

The amount of money you’re saving using this PBX for your office over another PBX means you can afford to purchase the supported EPM. Support the people who give you the opportunity to have an incredibly cheap yet reliable and supported PBX.

I certainly appreciate Sangoma for distributing FreePBX - I think that it’s a great product. However in this case I am installing three separate systems for a small business who has already paid for the system. So to go back to them to ask them to pay the $800 or whatever for three EndPoint managers would be quite problematic at this point. I’ve been using the OSS Endpoint manager for several years and I know how to make it work well and I am hoping that the install issue gets solved. And as far as supporting Sangoma we purchased three PRI cards for this customer (for their three servers) so the $2500 or so I feel is a support to Sangoma. (I love the Sangoma PRI cards and we purchased many of them for our customers over the last 6 or 7 years).
If anyone has any thoughts on how I can get this OSS End Point module installed I would certainly enjoy hearing their suggestions.

You realize the commercial EPM is only 75.00 for this very reason. Keep it cheap so everyone can afford it

No, actually I didn’t. I thought that you had to by the system builder package for $250 (or whatever). So that’s good to know. However I still would like to be able to get the OSS End Point manager working again since I’m familiar with it and have done a lot of modifications to the Polycom configs over the years…

Understand. Sorry not helpful on that. Its not supported by us and community supported and built.

If you do go down the OSS EP route, you may find this handy:

You’ll need two files - p.php and another one. Look in your current p.php and it will have an odd "return “a” followed by exit in a function, which breaks it. That is for http provisioning, I don’t know whether tftp still works - probably does.

Since you’re doing it for another client, the cost would be $225 for all 3 sites. How much more are they paying you in hours to get the OSS EPM to work? Probably more than that $225.

It is also commercially supported, that’s a big deal to my clients

If you don’t want a long drawn out explanation just add an extra hour for your time. If you are not billing $125.00 or more you are not charging the client enough.

David,
Thanks for your response! I did find that echo & exit commands that you mentioned in /var/www/html/admin/modules/endpointman/provisioning/p.php. But even after removing these statements and removing/re-installing the End Point module I still get the same effect: I can’t see the End Point Manager menus after performing an install which otherwise looks to be successful.
Thanks… Dave

If the menus don’t exist then the module is not installed. If the module says “Module not found” then the module is not installed. These are not freepbx bugs.

Ok, after creating a VM (to test my issue) with the latest FreePBX I can get OSS Endpoint Manager (13,0.6.7) to install w/out any problems. But I have three physical servers already built that still won’t allow the OSS Endpoint Manager (13.0.6.7) to install correctly (with menus) even though these three servers have been updated and are now up to date (FreePBX 10.13.66-13). So it seems to me that something in the FreePBX Distro (10.13.66-12) caused a problem with the OSS Endpoint Manager install and now that it’s “broken” no amount of uninstalling and re-installing this module fixes it. So my question: Does anyone know how to manually remove a module from FreePBX so that no traces of it remain? When I try to remove OSS Endpoint Manager from my “broken” physical servers I get “Failed to run un-installation scripts”. I’m assuming that if I can manually clear out this module from FreePBX then I’ll be able to install it and have it work. If anyone has any ideas I would greatly appreciate hearing them.

After doing some more experimenting here is some more information (for anyone who is interested):

  • Yes, this fresh install of FreePBX Distro 10.13.66-13 does allow me to install the OSS Endpoint manager and the menus do appear. But when I try to Uninstall the module I still get “Failed to run un-installation scripts”.

  • When I try to use the command-line to install this module (/var/lib/asterisk/bin/module_admin install endpointman) I get:
    PHP Fatal error: Class ‘FreePBX\modules\PEAR_Error’ not found in /var/www/html/admin/modules/endpointman/lib/json.class.php on line 860
    Whoops\Exception\ErrorException: Class ‘FreePBX\modules\PEAR_Error’ not found in file /var/www/html/admin/modules/endpointman/lib/json.class.php on line 860
    Stack trace:

    1. () /var/www/html/admin/modules/endpointman/lib/json.class.php:860

So while different versions of FreePBX (and/or Asterisk) seem to be dealing with the installation of this module differently it does seem like there is a problem with the OSS Endpoint Manager module itself.

Again if anyone has any ideas on how to fix the OSS Endpoint Manager install I’d be glad to hear what they are.

You can find the developer here: https://github.com/vsc55/endpointman