OSLEC works but deactivate after few minutes

I have installed
Asterisk (Ver. 11.9.0)
Hardware: Digium Tdm410 with 2 FXO.

At the graphical menu in DAHDi is activated but if I don’t modify the file /etc/dahdi/system.conf adding echocanceller=oslec,1-2 dont work.
When I modify the file and restart asterisk works like a champ but then in some minutes the echo comes back and the line of echo canceller disappear.

I already search for disable the dahdi helper in module admin and I dint found the helper just the entry module.


All echo cancelers have limits. You may be exceeding those limits. You likely have issues at a provider level, internal wiring or potentially the physical port. It sounds like somewhere a capacitance is building up. Typical things like fxotune will not work if the hybrid is not consistent

Tnx for the fast response, i dint explain correctly (sorry about my terrible English), the problem is the echo canceling just disappear at the configuration file. And I need to put back for set work again, I dont know if the order maters or what im doing wrong my files lok like this.


I added manualy the “echocanceller=oslec,1-2” boot then the file modifies and appears only like this.
And I lost the echo canceling.

At the header sets don’t modify the file but is the only way I can activate the echo cancelling (at the administration page general settings is set on) but doesn’t appear on at DAHDi page.

at the configuration FreePBX Advanced Settings the “Disable DAHDi Configuration Writes” is set to FALSE