Oslec module not present

Hi, im new in this distro, I have migrated the prior asterisk to this new Freepbx and now im having problems with Echo.

First of all versions:
Dahdi 2.7.0
Asterisk 11.5.1
Linux kernel: 2.6.32-358.18.1.el6.i686
Freepbx: freepbx-2.11.0beta2

The problem is that Im enabling the Echocancel =yes, also include the echocanceller=oslec,1-4 and when dahdi_cfg -vv it shouws the error “Invalid Argument”

I also tried the hwec and it shows the error

When I use mg2 it goes perfect.

Does any one have any idea what is happening?

Have you read this (reading all the comments were made too)? maybe you will find some tips.

Yes I have read it, and what I see is that this guy was also including the line “echocanceller=oslec,1-2” same as me, but unfortunately for me does not work, this is the way where I obtain the invalid argument message…

I can go far with my problem, I dismiss my installed hardware echo canceller (beacuse I am unable to make it work) and then when I try with oslec same result. Actually Im with mg2 but wanna use hwec or oslec.

To diagnose your issue you should start to provide a little bit more information about your system (updated or not? are you running FreePBX Distro 4.211.64-7 or what?)/FreePBX Modules (updated or not?)/Which Kernel Modules were loaded? …more or less as reported on the comments of that Ticket.

What happens if, from CLI, you run: dahdi_cfg -vvv ?
What happens if, from CLI, you run: yum list dahdi-linux* (and also yum list dahdi-tools*) ?
What happens if, from CLI, you run: lsmod|grep dahdi ?

Did you check (using tail -f) the freepbx.log while configuring DAHDi on GUI just to see what really happens?

Sorry, I do not run Freepbx distro, I run AsteriskNow with FreePBX

dahdi_cfg -vvv

[[email protected] dahdi]# dahdi_cfg -vvv
DAHDI Tools Version - 2.7.0

DAHDI Version: 2.7.0
Echo Canceller(s): MG2

Channel map:

Channel 01: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 01)
Channel 02: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 02)
Channel 03: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 04)

4 channels to configure.

Setting echocan for channel 1 to oslec
DAHDI_ATTACH_ECHOCAN failed on channel 1: Invalid argument (22)

lsmod|grep dahdi
[[email protected] dahdi]# lsmod|grep dahd
dahdi_echocan_mg2 4625 5
dahdi_transcode 5240 1 wctc4xxp
dahdi_voicebus 48437 2 wctdm24xxp,wcte12xp
dahdi 204899 21 dahdi_echocan_mg2,xpp,dahdi_transcode,wcb4xxp,wctdm,wcfxo,wctdm24xxp,wcte11xp,wct1xxp,wcte13xp,wcte12xp,dahdi_voicebus,wct4xxp
crc_ccitt 1369 2 wctdm24xxp,dahdi

yum list dahdi-linux*

Installed Packages
dahdi-linux.i686 2.7.0-1_centos6

I can not load the oslec module from command line its like it does not exist on my server…

May I need to recompile the dahdi module?

It seems that “dahdi_echocan_oslec” Kernel Module isnt’t loaded.

Did you verify if “dahdi_echocan_oslec” Kernel Module could be probed? …with:

modprobe dahdi_echocan_oslec

Read also this.

Yes its not loaded, also it can not be loaded via modprobe:
FATAL: Module dahdi_echocan_oslec not found.

So, must be that CentOS does not come with oslec support?

On the contrary…FreePBX Distro, which is based on CentOS (the latest Track 4 uses CentOS 6.4 as operative system over which Asterisk and FreePBX run), has a DAHDI implementation which supports OSLEC as per Ticket I showed you (I can also state that my system, a FreePBX 4.211.64-7, is currently working with that Software Echo Canceller on a HFC-S “Cologne Chip” based ISDN PCI Card without any problem).

You’re not running FreePBX Distro but AsteriskNow with FreePBX added: despite AsteriskNow is CentOS based too there would be other parts that differ (DAHDI rpm? Kernel?).

the oslec module needs to be in the staging part of the dahdi code when you compile it, some distro’s do that, some don’t.

One answer is to download the digium dahdi code , add the oslec code to the source tree (recipes out there in google land) and then “make” and “make install” dahdi and its ancilliary binary tools.

The dahdi module needs to be compiled against your running kernel, so any arbitrary rpm that you try and install it from will either work . . . or not depending on what your kernel is and how the module in the rpm was compiled :slight_smile: