Option 66 on Pseries phones not working

I am following article:
https://wiki.freepbx.org/display/PHON/Setup+Phone+with+DHCP+Option+66

I am using sip:[email protected]:5060

I tried IP and FQDN with no luck. I have to manually type in the IP of the pbx. Any thoughts? S-series deploy fine with option 66

you seem to have the correct format , but note you can specify transport as well… for instance mine looks like sip:[email protected]:5060;transport=tcp

packet capture from here is all you need to see whats actually in the offer , and you should also see if there is an existing redirect via sangoma portal … it will ignore option 66 if one exists

if you are sharing S and P series and want a common option for the bunch use the traditional option string … it will work for both whereas the DPMA option will not work for S series