Openvpn wont startup

Hi,

I am running FreePBX 14.0.1.4. In previous versions I have configured Openvpn to start with “service openvpn on” and “service openvpn start”

Trying this now in the latest version based on Centos 7 I run :“systemctl enable openvpn” and “systemctl start openvpn” but in both instances I get an error like:

[[email protected] /]# systemctl start openvpn Failed to start openvpn.service: Unit not found. [[email protected] /]# systemctl enable openvpn Failed to execute operation: No such file or directory [[email protected] /]# [[email protected] /]# systemctl list-unit-files | grep openvpn [email protected] disabled ope[email protected] disabled [email protected] disabled [[email protected] /]# systemctl enable [email protected] Failed to execute operation: Unit name [email protected] is missing the instance name. [[email protected] /]# systemctl enable openvpn Failed to execute operation: No such file or directory [[email protected] /]# systemctl enable [email protected] Failed to execute operation: Unit name [email protected] is missing the instance name. [[email protected] /]# systemctl enable [email protected] Failed to execute operation: Unit name [email protected] is missing the instance name.

The ‘@’ symbol there is looking for a specific configuration file, eg the ‘instance name’ under the openvpn directory /etc/openvpn

eg if you had /etc/openvpn/myconfig.conf

then you’d run

systemctl start [email protected]

This is how we start and stop the support vpn and the phone vpn.

Along with that you’ll need to yum upgrade sangoma-pbx

1 Like

100% - thank you!