Oneway audio and disconnect short time of call with grandstream FXO gateway

Hello all with the Help of avayax on the Grandstream FXO gateway trying to connect to it.That i ran into a couple of problems one would be a oneway audio If i call from my office phone to my cellphone meaning if i talk on my office phone micrphone to my cellphone there is audio coming out of my cellphone speaker. But if i talk from my cellphone microphone to my office phone speaker part there is no audio at all.

Second problem is after 30 to 45 seconds of call it disconnects the call not sure why Never seen that before.

Oh i forgot one last problem. Sometimes when i call out from the office phone it says caller is not picking up i never heard this before.

Can someone please help me out

The dropped calls could be due to no RTP activity (no audio). It’s normal for calls to be terminated if there is no audio. Check the CLI why the calls drop. You can do rtp debug as well (rtp debug on).

Now I will let others chime in.

One way or no audio is almost always network related (NAT, etc.)

I found this

and i found this

and for nat i found this

and this

How do i check the CLI and the rtp debug?

asterisk -vvvvr
Then make a call. If you see a message after 30 seconds “no rtp activity for … seconds” you know what is happening. No audio.
You can also do
rtp set debug on
rtp set debug off

This is what i got from the call now

– Executing [[email protected]:1] Macro(“SIP/759-0000b3d3”, “user-callerid,LIMIT,EXTERNAL,”) in new stack
– Executing [[email protected]:1] Set(“SIP/759-0000b3d3”, “TOUCH_MONITOR=1472322002.50479”) in new stack
– Executing [[email protected]:2] Set(“SIP/759-0000b3d3”, “AMPUSER=759”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/759-0000b3d3”, “0?report”) in new stack
– Executing [[email protected]:4] ExecIf(“SIP/759-0000b3d3”, “1?Set(REALCALLERIDNUM=759)”) in new stack
– Executing [[email protected]:5] Set(“SIP/759-0000b3d3”, “AMPUSER=759”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/759-0000b3d3”, “0?limit”) in new stack
– Executing [[email protected]:7] Set(“SIP/759-0000b3d3”, “AMPUSERCIDNAME=521 MHP NJ”) in new stack
– Executing [[email protected]:8] GotoIf(“SIP/759-0000b3d3”, “0?report”) in new stack
– Executing [[email protected]:9] Set(“SIP/759-0000b3d3”, “AMPUSERCID=759”) in new stack
– Executing [[email protected]:10] Set(“SIP/759-0000b3d3”, “__DIAL_OPTIONS=Ttr”) in new stack
– Executing [[email protected]:11] Set(“SIP/759-0000b3d3”, “CALLERID(all)=“521 MHP NJ” <759>”) in new stack
– Executing [[email protected]:12] GotoIf(“SIP/759-0000b3d3”, “0?limit”) in new stack
– Executing [[email protected]:13] ExecIf(“SIP/759-0000b3d3”, “1?Set(GROUP(concurrency_limit)=759)”) in new stack
– Executing [[email protected]:14] GosubIf(“SIP/759-0000b3d3”, “7?sub-ccss,s,1(from-internal,6099541532)”) in new stack
– Executing [[email protected]:1] ExecIf(“SIP/759-0000b3d3”, “0?Return()”) in new stack
– Executing [[email protected]:2] Set(“SIP/759-0000b3d3”, “CCSS_SETUP=TRUE”) in new stack
– Executing [[email protected]:3] GosubIf(“SIP/759-0000b3d3”, “0?monitor_config,1(from-internal,6099541532):monitor_default,1(from-internal,6099541532)”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/759-0000b3d3”, “0?is_exten”) in new stack
– Executing [[email protected]:2] StackPop(“SIP/759-0000b3d3”, “”) in new stack
– Executing [[email protected]:3] Return(“SIP/759-0000b3d3”, “FALSE”) in new stack
– Executing [[email protected]:15] ExecIf(“SIP/759-0000b3d3”, “0?Set(CHANNEL(language)=)”) in new stack
– Executing [[email protected]:16] GotoIf(“SIP/759-0000b3d3”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,30)
– Executing [[email protected]:30] Set(“SIP/759-0000b3d3”, “CALLERID(number)=759”) in new stack
– Executing [[email protected]:31] Set(“SIP/759-0000b3d3”, “CALLERID(name)=521 MHP NJ”) in new stack
– Executing [[email protected]:32] Set(“SIP/759-0000b3d3”, “CDR(cnum)=759”) in new stack
– Executing [[email protected]:33] Set(“SIP/759-0000b3d3”, “CDR(cnam)=521 MHP NJ”) in new stack
– Executing [[email protected]:34] Set(“SIP/759-0000b3d3”, “CHANNEL(language)=en”) in new stack
– Executing [[email protected]:2] Gosub(“SIP/759-0000b3d3”, “sub-record-check,s,1(out,6099541532,dontcare)”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/759-0000b3d3”, “0?initialized”) in new stack
– Executing [[email protected]:2] Set(“SIP/759-0000b3d3”, “__REC_STATUS=INITIALIZED”) in new stack
– Executing [[email protected]:3] Set(“SIP/759-0000b3d3”, “NOW=1472322002”) in new stack
– Executing [[email protected]:4] Set(“SIP/759-0000b3d3”, “__DAY=27”) in new stack

and

– Executing [[email protected]:5] Set(“SIP/759-0000b3d3”, “__MONTH=08”) in new stack
– Executing [[email protected]:6] Set(“SIP/759-0000b3d3”, “__YEAR=2016”) in new stack
– Executing [[email protected]:7] Set(“SIP/759-0000b3d3”, “__TIMESTR=20160827-142002”) in new stack
– Executing [[email protected]:8] Set(“SIP/759-0000b3d3”, “__FROMEXTEN=759”) in new stack
– Executing [[email protected]:9] Set(“SIP/759-0000b3d3”, “__MON_FMT=wav”) in new stack
– Executing [[email protected]:10] NoOp(“SIP/759-0000b3d3”, “Recordings initialized”) in new stack
– Executing [[email protected]:11] ExecIf(“SIP/759-0000b3d3”, “0?Set(ARG3=dontcare)”) in new stack
– Executing [[email protected]:12] Set(“SIP/759-0000b3d3”, “REC_POLICY_MODE_SAVE=”) in new stack
– Executing [[email protected]:13] ExecIf(“SIP/759-0000b3d3”, “0?Set(REC_STATUS=NO)”) in new stack
– Executing [[email protected]:14] GotoIf(“SIP/759-0000b3d3”, “3?checkaction”) in new stack
– Goto (sub-record-check,s,17)
– Executing [[email protected]:17] GotoIf(“SIP/759-0000b3d3”, “1?sub-record-check,out,1”) in new stack
– Goto (sub-record-check,out,1)
– Executing [[email protected]:1] NoOp(“SIP/759-0000b3d3”, “Outbound Recording Check from 759 to 6099541532”) in new stack
– Executing [[email protected]:2] Set(“SIP/759-0000b3d3”, “RECMODE=dontcare”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/759-0000b3d3”, “1?Goto(routewins)”) in new stack
– Goto (sub-record-check,out,7)
– Executing [[email protected]:7] Gosub(“SIP/759-0000b3d3”, “recordcheck,1(dontcare,out,6099541532)”) in new stack
– Executing [[email protected]:1] NoOp(“SIP/759-0000b3d3”, “Starting recording check against dontcare”) in new stack
– Executing [[email protected]:2] Goto(“SIP/759-0000b3d3”, “dontcare”) in new stack
– Goto (sub-record-check,recordcheck,3)
– Executing [[email protected]:3] Return(“SIP/759-0000b3d3”, “”) in new stack
– Executing [[email protected]:8] Return(“SIP/759-0000b3d3”, “”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/759-0000b3d3”, “0 ?Set(CDR(accountcode)=)”) in new stack
– Executing [[email protected]:4] Set(“SIP/759-0000b3d3”, “MOHCLASS=default”) in new stack
– Executing [[email protected]:5] ExecIf(“SIP/759-0000b3d3”, “1?Set(TRUNKCIDOVERRIDE=6097779207)”) in new stack
– Executing [[email protected]:6] Set(“SIP/759-0000b3d3”, “_NODEST=”) in new stack
– Executing [[email protected]:7] Macro(“SIP/759-0000b3d3”, “dialout-trunk,3,6099541532,off”) in new stack
– Executing [[email protected]:1] Set(“SIP/759-0000b3d3”, “DIAL_TRUNK=3”) in new stack
– Executing [[email protected]:2] GosubIf(“SIP/759-0000b3d3”, “0?sub-pincheck,s,1()”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/759-0000b3d3”, “0?disabletrunk,1”) in new stack
– Executing [[email protected]:4] Set(“SIP/759-0000b3d3”, “DIAL_NUMBER=6099541532”) in new stack
– Executing [[email protected]:5] Set(“SIP/759-0000b3d3”, “DIAL_TRUNK_OPTIONS=Ttr”) in new stack
– Executing [[email protected]:6] Set(“SIP/759-0000b3d3”, “OUTBOUND_GROUP=OUT_3”) in new stack
– Executing [[email protected]:7] GotoIf(“SIP/759-0000b3d3”, “0?nomax”) in new stack
– Executing [[email protected]:8] GotoIf(“SIP/759-0000b3d3”, “0?chanfull”) in new stack
– Executing [[email protected]:9] GotoIf(“SIP/759-0000b3d3”, “0?skipoutcid”) in new stack
– Executing [[email protected]:10] Set(“SIP/759-0000b3d3”, “DIAL_TRUNK_OPTIONS=Tt”) in new stack
– Executing [[email protected]:11] Macro(“SIP/759-0000b3d3”, “outbound-callerid,3”) in new stack
– Executing [[email protected]:1] ExecIf(“SIP/759-0000b3d3”, “0?Set(CALLERPRES()=)”) in new stack
– Executing [[email protected]:2] ExecIf(“SIP/759-0000b3d3”, “0?Set(REALCALLERIDNUM=759)”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/759-0000b3d3”, “1?normcid”) in new stack
– Goto (macro-outbound-callerid,s,6)
– Executing [[email protected]:6] Set(“SIP/759-0000b3d3”, “USEROUTCID=”) in new stack
– Executing [[email protected]:7] Set(“SIP/759-0000b3d3”, “EMERGENCYCID=”) in new stack
– Executing [[email protected]:8] Set(“SIP/759-0000b3d3”, “TRUNKOUTCID=6097779207”) in new stack
– Executing [[email protected]:9] GotoIf(“SIP/759-0000b3d3”, “1?trunkcid”) in new stack
– Goto (macro-outbound-callerid,s,14)
– Executing [[email protected]:14] ExecIf(“SIP/759-0000b3d3”, “1?Set(CALLERID(all)=6097779207)”) in new stack
– Executing [[email protected]:15] ExecIf(“SIP/759-0000b3d3”, “0?Set(CALLERID(all)=)”) in new stack
– Executing [[email protected]:16] ExecIf(“SIP/759-0000b3d3”, “1?Set(CALLERID(all)=6097779207)”) in new stack
– Executing [[email protected]:17] ExecIf(“SIP/759-0000b3d3”, “0?Set(CALLERPRES()=prohib_passed_screen)”) in new stack
– Executing [[email protected]:18] Set(“SIP/759-0000b3d3”, “CDR(outbound_cnum)=6097779207”) in new stack
– Executing [[email protected]:19] Set(“SIP/759-0000b3d3”, “CDR(outbound_cnam)=”) in new stack
– Executing [[email protected]:12] GosubIf(“SIP/759-0000b3d3”, “0?sub-flp-3,s,1()”) in new stack
– Executing [[email protected]:13] Set(“SIP/759-0000b3d3”, “OUTNUM=6099541532”) in new stack
– Executing [[email protected]:14] Set(“SIP/759-0000b3d3”, “custom=SIP/GXW4108”) in new stack
– Executing [[email protected]:15] ExecIf(“SIP/759-0000b3d3”, “0?Set(DIAL_TRUNK_OPTIONS=M(setmusic^default)Tt)”) in new stack
– Executing [[email protected]:16] ExecIf(“SIP/759-0000b3d3”, “0?Set(DIAL_TRUNK_OPTIONS=TtM(confirm))”) in new stack
– Executing [[email protected]:17] Macro(“SIP/759-0000b3d3”, “dialout-trunk-predial-hook,”) in new stack
– Executing [[email protected]:1] MacroExit(“SIP/759-0000b3d3”, “”) in new stack
– Executing [[email protected]:18] GotoIf(“SIP/759-0000b3d3”, “0?bypass,1”) in new stack
– Executing [[email protected]:19] ExecIf(“SIP/759-0000b3d3”, “1?Set(CONNECTEDLINE(num,i)=6099541532)”) in new stack
– Executing [[email protected]:20] ExecIf(“SIP/759-0000b3d3”, “1?Set(CONNECTEDLINE(name,i)=CID:6097779207)”) in new stack
– Executing [[email protected]:21] GotoIf(“SIP/759-0000b3d3”, “0?customtrunk”) in new stack
– Executing [[email protected]:22] Dial(“SIP/759-0000b3d3”, “SIP/GXW4108/6099541532,300,Tt”) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called SIP/GXW4108/6099541532
– SIP/GXW4108-0000b3d4 is ringing
– SIP/GXW4108-0000b3d4 answered SIP/759-0000b3d3
> 0x7fc5ac64ad20 – Probation passed - setting RTP source address to 71.188.94.66:21781
[2016-08-27 14:20:39] NOTICE[2592]: chan_sip.c:29240 check_rtp_timeout: Disconnecting call ‘SIP/GXW4108-0000b3d4’ for lack of RTP activity in 31 seconds
– Executing [[email protected]:1] Macro(“SIP/759-0000b3d3”, “hangupcall,”) in new stack
– Executing [[email protected]:1] ExecIf(“SIP/759-0000b3d3”, “0?Set(CDR(recordingfile)=.wav)”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/759-0000b3d3”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,4)
– Executing [[email protected]:4] Hangup(“SIP/759-0000b3d3”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/759-0000b3d3’ in macro ‘hangupcall’
== Spawn extension (macro-dialout-trunk, h, 1) exited non-zero on ‘SIP/759-0000b3d3’
== Spawn extension (macro-dialout-trunk, s, 22) exited non-zero on ‘SIP/759-0000b3d3’ in macro ‘dialout-trunk’
== Spawn extension (from-internal, 6099541532, 7) exited non-zero on ‘SIP/759-0000b3d3’

I have to leave soon so not sure what much more i can do into Monday we are closed here tomorrow and i can’t remote in so. I’m not sure what else to to.

There is no audio being passed.
This has to do with your network configuration, be it your VPN, port forwarding or however your server gets to talk to your VoIP gateway behind NAT.
You have to familiarize yourself with that, I don’t think people on this forum will be able to help you, cause nobody can look at your network configuration.
Maybe you need to pay someone to look at this closely and make this work for you.

Good luck.

Try nat=yes in the trunk peer settings.

There are tons of threads on one way or no audio issues on this forum here.

Wiki on audio issues.
http://wiki.freepbx.org/pages/viewpage.action?pageId=24051965

Hello Avayax i think i know what the audio problem is about. At lease i think so. We recently have bandwidth problems I didn’t think it would be a problem with the phones But it might be. our normal internet speed is 80/80 mb connection well it’s suppose to be 100/100 mb connection. but mostly get between 75 and 80 the most. When they setup the VPN router some settings must be off because the bandwidth is down to 5/7 mb connection. Sense we have so many computers on the network 15 desktops and the PBX phone that is maybe why the audio problem is having. They are still trying to figure out how to fix the bandwidth problem. But honestly i didn’t think it would of effected the audio and i could be wrong on that.

If you worry about bandwidth you can do Quality of service on your router and preference VoIP over other traffic, if the router can do that, but honestly, I am 99% convinced, that your bandwidth problems are not causing your audio issue.
You have no audio at all and no rtp packets are sent whatsoever. With bandwidth congestion you would have dropouts, etc, but you would get at least some audio.

Try nat=yes in the trunk peer settings.

The solution most likely is in your VPN or NAT setup. Maybe your VPN settings don’t allow you to pass rtp packets through certain ports. You could talk to the guy who set this up.
Maybe your NAT settings under Asterisk SIP settings on FreePBX GUI are wrong.

Make sure the RTP port settings in the gateway and as shown in SIP Settings on the pbx are compatible. I would set that local RTP start port in the gateway to 10001 or thereabouts for starters.

Thank you both i will look at it tomorrow because i have no access from my home. I will check the RTP ports on both pbx and grand stream box.

Hello i found a local RTP Port: it is set to 5004 is that the one i change to 10001?

It’s a good place to start.

It looks like that was the problem. I changed to 10001 and rebooted the gateway Now I’m able to here some sound on both ends.

I got caught out with this exact same issue on a Dinstar cellular gateway, took me forever to find it.

I was thinking of setting up a GSM PBX for my family that is Poland the cost is nuts to call there and call back.