One-way connection using microsip over openvpn


First I need to say that I am not a SIP expert. Forgive me if my question is not clear enough.

I am trying to setup MicroSIP to act as a phone extension on our company FreePBX / Asterisk server. I am running microsip on my home computer which is connected to the office network via openvpn (pfSense).

I have created a new extension in freepbx with user / password and entered that in microsip . Microsip says that it is OnLine. From that point, I can call my cell phone using microsip as I would from within the office and I can also call that extension from my cell phone. However, microsip does not receive any audio but it can transmit ( microphone working fine). I do however hear the microsip phone ringing when I get a call.

I suspected a firewall issue or UPD packets being blocked. I turned off windows firewall and defender.
I also setup the asterisk extension to use only TCP only for the transport. From the asterisk server, I can connect to port 5060 on my home PC. I also tried to change the codecs supported by microsip in case that would be an issue.

I tried to look in asterisk log but I cannot see any obvious issues with connection during the calls but I am not too sure what to look for. I know that there are also the RTP ports (10000 - 20000 ) to check for but I dont know how to check them. I do not see any listening ports in the range on my home PC.

My home pc is connected to the office via a vpn so my ip is on a different subnet but the route seem to work both ways ( I can ping my pc from asterisk and vice versa).

Our installation is pretty old: we have FreePBX 2.10 and asterisk .

What could be the issue and how can I run more informative tests ? Any hint would be useful

Thank you


The most common cause for something like this is that the VPN subnet is not included in the “Local Networks” area of Asterisk SIP Settings. I assume that the version you’re using has that.

You already know that your system is past end of life, as it’s successor, and its successor’s successor. You should have a plan in place to migrate to something supported.

Some softphones need that the extension be configured to NAT=yes even though they are connecting through a VPN because they fail to correctly detect the IP of the VPN.

That fixed it. I set NAT=yes in the extension and now I have two way audio.

Thank you.

Thank you. The subnet was already defined as local net in asterisk. And, yes, we have plans to update this old version as soon as we can get back in the office.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.