One way Audio


#1

Hi,

I ve the problem mentioned in the title.
Here is my setup

eth0---->LAN FreePBX (10.1.1.199)
eth1---->SIP Provider network

Also there are 7 remote sites connected through VPN on the Main site 10.1.1.0/24 where FreePBX is.
I ve a SIP trunk to my provider network which is registered correctly

When i make a call from SIP phone on a remote site to a mobile or another remote phone, in the traces from eth0 in the SDP packets there is an IP that its not on my network (172.16.32.26) and all the RTP packets are going to this IP address.

Any ideas ???


(Dave Burgess) #2

The unhelpful (but correct) answer is that your NAT settings are incorrect.

The reason it’s unhelpful is because there are about five places that affect the NAT settings.

You need to look in all of the following:

  • Under Advanced Settings -> SIP Settings, make sure all of the local nets and external addresses are set correctly.
  • In your Trunk definitions, make sure any NAT settings you are using are correct.
  • In your Extensions definitions, make sure the NAT settings are correct.
  • If you have NAT settings in your actual phones (real or soft), make sure they are all set correctly.
  • Make sure your Router isn’t helping you with SIP-ALG or some other impediment to success.

(Tom Ray) #3

Would this be the local IP of the remote phone?


#4

No, not at all i cannot even ping this IP address.


(Tom Ray) #5

So what are the subnets at the remote sites? You don’t have a VPN on every phone so they are going through your VPN at the router. That means they still have IPs from their local network. What is the IP of the phone that you are testing with?

Random IPs don’t just get shoved in there. Something is doing it.


#6

Hi,

All my remote sites have a site-to-site VPN connection so the VPN is running from the router of the remote site and not from the phone itself.

The IP of the phone that ia ma doing my tests is 10.10.1.251


#7

The remote subnets are 10.10.1.0/24, 10.10.20.0/24, 192.168.22.0/24, 192.168.23.0/24, 192.168.24.0/24 and 192.168.25/0/24


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.