One Way Audio Problem - Trunk IP Authentication

Hi all,

I have 2 SIP Trunks set up on my pbx (Version, one registers with a provider and one uses IP authentication rather than registering with the provider. So I have port 5060 and the RTP ports forwarded (specified in Asterisk SIP Settings) under ‘RTP Port Ranges’ to the pbx.

The provider that I register with works perfectly, however the other one has a weird problem. Basically if I ring it from my mobile and answer it I can hear myself on the mobile for a few seconds, and then it just goes silent. However if I say nothing when I answer the phone for a few seconds and then speak the call works two way. If it is in a queue or if the system answers it using a message before the call, there is perfect two-way audio. I am sort of baffled to be quite honest.

I tried a different provider that uses IP Authentication and I have the same problem.

Here are the settings for the provider I am having problems with:
–PEER Details:
host=[IP Address of Provider’s SBC]

–USER Context:

–USER Details:

–Register String:

Anyone have any ideas how to fix this?

It is your nat/router box misconfigured, they need to maintain all rtp connection without translation and without timeing out. Most can, some have “helper” functions (alg or some such nonesense name) that break everything, don’t use them.

Do you have a way to watch the traffic make it through the router/firewall successfully or is it getting blocked?
Verify you have your SIP External IP address set properly.

Thanks for your help.

I have the SPI Firewall feature led disabled on the firewall.

I have tried disabling the firewall, but it made no difference.

The thing that is wierd is that if the call is sent to a message or IVR played by the pbx the call completes with 2 way audio. Only when it is answered do I have problems.

Baffled to be honest.

Seems to be fixed now. Not sure what happened there for a while. Did an amportal restart and working fine now. I will update in due course. Weird.

Happy Christmas!

Still having problems, it happens randomly and still as above.

Works fine when call is sent to IVR first, but if called directly there is one way audio.

Have you configured the codecs for the trunks, extensions etc?
Looking at the logs will tell you the answer.

Hi there,

I managed to see my problem. Pretty idiotic on my part.

I forgot to include the following in the Trunk Incoming Settings:


Everything is working fine now. The trunk supports alaw, and we do not use g729 or ulaw so I just left it like that. No one way audio problems now.

One of the other things that could cause problems was that the provider did not support gsm. So got rid of that in the trunk settings above.

The problem was that the PBX was set as Static IP and not Public IP. Problem solved.