One way audio on certain external numbers

PIAF Green
Free PBX
Asterisk 11.3.0

Tried to post in PIAF forum but had permissions problem.

Most of our calls go through without problem. I can call my cell phone, and many other numbers without issue. However 3 landlines in particular one which is a SIP number has no audio on my end. I dial the call and hear nothing (no ringing just silence) however they hear the ring and audio.

I recently moved to a server. I have set all of the extensions to nat = yes
I added externip=publicIP in sip_custom.conf
I added nat=no,externip=publicIP,fromdomain=(DNS A Record - same as server hostname) to sip_nat.conf
I have added localhost, serverhostname to hosts file

We also have had intermittent problems with extensions being unreachable even though they are online (they can’t call each other but then a minute later it works file). We have not had problems with incoming calls everything works fine there.

Any help on where to troubleshoot or settings I might try would be much appreciated. We have a verizon router/firewall which does not have any sip related settings. I have the same problem with x-lite softphones - I have tried setting to a public STUN server. Nothing so far has made any difference and I suspect it may not be a NAT issue but rather a configuration problem on the server.

Sounds like everything is setup correctly, what type of connectivity to you have where the extensions are?
Are all your extensions in the same location?
Are you renting the server and getting the trunks from the same place?

All of our current extensions are behind the same firewall with high-speed fiber connection and a public IP. I recently enabled SIP-ALG on the Verizon FW with no noticeable change. In desperation I have tried temporarily turning off the FW on the PBX as well with no luck.

The RentPBX is a public facing VM with a static IP. We are using Flowroute for our trunk (been real happy with their service & pricing).

Flowroute has offered to look at a packet trace to help isolate the problem. I’ll post an update if that turns up anything.

It turns out the numbers we are dialing to only accept g729 however we are using ulaw as the preferred codec. The problem is in the translation. For some reason we place the call using ulaw and they respond with g729 and there is no audio on our end. If I place the call using g729 everything is fine. Anyone know why the translation would not work as expected?

I verified which codec was in use by issuing “sip show channels” in the asterisk console.

Have you purchased the necessary g729 licenses?

Based on some further searching it appears that you may use g729 without translating it without a license but to translate it you need the license which is why it wouldn’t translate. I’m not certain but that appears to be the case.


Asterisk can pass-through g729 without a license, but it can not operate on that channel.