On a new PBX just installed I notice an annoying echo, let's see how to solve it [SOLVED]


(Claudio Pelosi) #1

I just ran a FreePBX Asterisk Version: 13.27.0
Known an annoying echo generated by some VoIP Gateway [Grandstream GXW4108] but I can not handle …
I have documented and it would seem that our beloved FreePBX has weapons to compensate for the problem …
I saw this post that looks interesting: Hard ware echo cancellation problems

Now the /etc/asterisk/chan_dahdi.conf file is not present
But I found a file /etc/asterisk/chan_dahdi_additional.conf but empty

I can put there some parameters like:
echocancel = yes
echocancelwhenbridged = no

What are you saying on the right track?
Can I do better?
I await reply, thanks to all


#2

The GXW4108 is a SIP Gateway, so it is not controlled by dahdi at all. The gateway has onboard echo cancellation, just make sure it is enabled.


(Claudio Pelosi) #3

In fact I had already done yesterday, and indeed the echo has been solved!
I would still like to address the topic … If I had to solve with asterisk …?


#4

The echo canceller is not managed by Asterisk. It is managed by the gateway or by DAHDI if you have a plug-in card.


(Claudio Pelosi) #5

I understood then only if he has sk onboard thanks!


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.