FreePBX | Register | Issues | Wiki | Portal | Support

[OFFTOPIC] How to configure CISCO VG224 with Asterisk/FreePBX


(Miguel Sanz) #1

Hello good morning,

On this moment I have this configuration:

Asterisk <----> Cisco Call Manager <–MGCP–> Gateway PRI Cisco 2801
|
|<---------MGCP----------> Gateway FXS Cisco VG224

On my Asterisk PBX I have 650 IP-phones registered and I want to migrate the VG224 to Asterisk.
And when I migrate the VG224 I want to migrate 2801 and swicth off the CCM

I have had several problems with VG224:

  1. When I tried to register 1 X FXS port of my VG224 on my Asterisk the port didnt register with this config:
    sip.conf:
    [77001]
    type = friend
    host =dynamic
    secret=pepito
    dtmfmode=rfc2833
    canreinvite=no
    context=from-internal
    trustrpid=yes
    sendrpid=no
    nat=no
    port=5060
    qualify=yes
    qualifyfreq=60
    transport=udp
    callcounter=yes
    faxdetect=no

If I do the same with a Grandstream 4224 (for example) I can register the extension without any problems.

In the VG224 I created a dial peer associated to extension 77001 with pass pepito and if I executed CLI> sip show peers ,the exension appears with UNKNOWN status

If I change host=dynamic to host = IP of VG224 then the status change to OK

Any idea about I needed to change the host from dynamic to IP of VG224 to can register the VG224 port on my Asterisk IPPBX?

  1. When I tried to do calls from an IP phone to an analog phone which was connected on VG224 (both phones registered on my Asterisk-IPPBX) it appeared an error which said: 400 Bad Request ‘Malformed/Missing…’

I did can observe that when I called to 77001 ext., on the INVITE message the field To was created on a bad manner:
To: sip:DireccionIPCentralita;transport=UDP
instead of
To: sip:77001@192.168.1.40;transport=UDP

If I add username = 77001 on sip.conf this problem disaapeared.

¿Any idea about why I need to use the username field? With grandstream 4224 I didnt have that kind of poblems

When I do calls between VOIP Phones I dont need to add the username parameter and the INVITE send the To:<… field good

  1. And the last problem is related with faxes:

If I connect an analog phone to the FXS port I can make internal/outbound calls and receive incoming calls without problems.

If I connect a FAX on the same FXS port:
I can call to the FAX from a phone and the FAX offhook.
I can call to the FAX from another FAX, then the FAX offhook and finally gives an error message.
If I try to call from the FAX the call is not cursed, even doesnt appears on the asterisk console ¿It does any sense? I think that at least it should appear a triying of call on the CLI (although the call finally can give an error)

Maybe the VG224 config that Im using is not correct. On vg224 I have created a dial peer with:

  • modem passthrough nse codec g711alaw
  • vad deactivated
  • echo canc. deactivate
  • dtmf-relay voip codec all mode nte-ca
    I have not limited the fax speed.

Best regards and thanks by your help

Miguel Sanz


(Robert White) #2

Hi Miguel,

Don’t know if you found a solution yet, but I threw together a tutorial for the Cisco Voice Gateway <-> FreePBX.


(Alisher Ahmedov) #3

Hi Robert White,

I read your blogspost. And i did it by your method.
I have any question about this. Can you help me?


(Robert White) #4

Sure, what seems to be the problem?


(Alisher Ahmedov) #5

I upgrade os version vg224 by your instruction. After then i put configuration file to it. My freepbx ip is 10.142.62.4/26. On vg224 f0/0 is 10.142.62.5/26. I created extention 7130(pjsip) in freepbx. And created trunk also. On vg224 internal call is working fine. But i cant to call 7130. 7130 registered on android phone, ip 10.142.62.10/26. ping is going to 10.142.62.4 and 10.142.62.5.

!
dial-peer voice 11 voip
description Outgoing Calls to FreePBX - 4 digit Internal
destination-pattern 713[0-9]
session protocol sipv2
session target ipv4:10.142.62.4
voice-class codec 1
dtmf-relay rtp-nte
no vad
!

I attachment images also this link.