Odd no audio issue on calls to P310 handset

We have a site with 400+ P310 handsets and all in all working OK ,

But we have a couple of odd audio issues, first one we were suffering with no audio on call pickups. This seems to have been solved with setting “send_connected_line” to no on the trunks

But ongoing issue is very odd one, user has to receive a call with an auth code read out
they recive the call and get no audio at all. But If a normal person calls their number all is OK, no audio issues at all.

attached is a copy of the call flow and the image of the audio playback and the audio is there from the carrier and out to the handset but they dont hear it but we get it here and in teh call recording of the call

only odd thing is in the calls that don’t work we get a CN rtp packet that we dont get on successful calls

at the moment direct_media is set to no but as most calls work ok i cant see that being the issue. But any ideas would be great.

see below

194 is the server
195 the carrier
10 the handset
213 carrier media server

Ok if anyone has this issue in the future the problem has been isolated to having “RTP Keep Alive” left at 60 , setting this to 0 seems to have solved the issue.
Thanks to Christian at Sangoma for this.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.