FreePBX | Register | Issues | Wiki | Portal | Support

Obihai 200 and Google Voice


(John Jarrett) #1

I have set up and Obihai 200 for use with my Google Voice account using the instructions found at https://community.freepbx.org/t/freepbx-and-google-voice/51586 which links to http://nerdvittles.com/?p=25846. It is simple to do by following the instructions. However…

My FreePBX will not allow the Obi200 to register. The Asterisk log file always shows Wrong Password:
[2018-09-03 06:27:14] NOTICE[1923] chan_sip.c: Registration from ‘sip:obigoogle@192.XXX.X.XXX’ failed for ‘192.XXX.X.XXX:5062’ - Wrong password

Not exactly sure how I could have messed that up but I ensured numerous times that the password was identical in my SIP Trunk Settings and on the Obi setup page which is their online cloud dashboard.

I would notice on the Cloud dashboard that after a few minutes the password under SIP Credentials would default to nothing and the Device Default would be checked. No matter how many times I reset the password and unchecked those boxes, it would always come back to this:
2018-09-03%2006_34_23-OBiTALK_%20OBi200

Looking directly at the firmware webpage on my Obi200 I see that the password seems t be set and the check boxes remain unchecked as the instructions state.

Incoming calls work just fine BTW. Outgoing calls, she states the number I am dialing is not in service!

1). I know that you can get higher granularity in the asterisk log file but can I find out what password the Obi is trying to send?
2). Is the Obi trying to encrypt the password?
3). Does anyone have any idea what setting didn’t take? I’ve gone over my setup several times and not seeing my boo boo if I made one.

Thanks

John


FreePBX and Google Voice
(Itzik) #2

Confirm that this is actually the port of the extension. (ChanSIP/PJSIP)

Also, try using a shorter password.


(John Jarrett) #3

Thanks so much for the reply!!

I did in fact try a much shorter password with no luck. The instructions for getting this to work state: “Normally, port 5061 is the default port assigned on the OBi side. If you get a failed registration, try 5060 and then 5062 and 5063.”

I have tried port=5060, port=5061, port=5062 port=5063 in my Trunks SIP details with no joy and the asterisk log file still shows failed or Wrong Password on port 5062 no matter what port I have assigned in the SIP details. I find that a tad weird.

I will scour the obi200 settings again and see if there is something else obvious but my initial thought was the port is somehow wrong. BUT the log file always stated wrong password on port 5062 so that’s what I put in my SIP details.

Interesting. It’s this kind of stuff that I love to learn about! But it is a tad frustrating when it should be a “piece of cake”!

John


(Itzik) #4

So if Asterisk says wrong password for port 5062 then the OBI is obviously still trying to register on port 5062.

For testing… I would set my driver on 5062 and then try again to register.


(John Jarrett) #5

Thank you again for the reply!

My apologies, but I am not certain by what you mean “set my driver”.

In my Trunk SIP details, I have set port=5062 as well as all other ports mentioned. No joy…

Do I have a defective Obi? And can I see what password is trying to be passed?

Thanks!


#6

I realize it’s been three months since you posted this so maybe you have found a solution already, but if not, someone posted a link to this article on Reddit today. Maybe it would be helpful to you.

How to use an Obihai 200 series VoIP device as a gateway between Google Voice and FreePBX


(John Jarrett) #7

@ Wanderer

I abandoned this as I learned, after a ton of Googling, that the method I was trying to make work by Nerdvittles is… to be polite, no good!

I have not reviewed the info you posted but I posted a link to another method that worked very well in this forum some time back. Don’t misunderstand the title in the link I am providing as the title given is the method’s author. I got chastised by posting/referring to it as a potential business solution because the word ITSP is used by that method’s author. “Gateway” in your referenced post is much better.


(Dave Burgess) #8

Also, remember that GV has recently updated their service yet again, so this whole thing sounds like it’s about to explode again.


(Tom Ray) #9

Well connecting to Google Voice via the Obi 2XX is fully acceptable they are valid devices for such connection. Using the Obi 2XX as your “gateway” to Google Voice is fine, doesn’t violate anything. You just have it make it so the PBX talks to the Obi and vice versa. So typical ATA stuff.

The issue that you are referring to is when people reversed engineered things to make Asterisk connect directly. That is the big no-no.


(Dave Burgess) #10

They’re on to us, though. :slight_smile: How long will it be before they figure this one out and screw with it like the other (like) 5 times? I’m convinced there’s a guy at Google that lurks here waiting for us to figure out yet another way to get to GV with Asterisk so he can figure out how to shut it down.


(Itzik) #11

IMO: I don’t think this is going to happen here. Google has an agreement with Polycom on that. So if the only way to get GV working is by using an OBI, then their sales will probably increase. So why should they stop supporting the OBI from being a “gateway”.