Number out of service after just making a call

I’m a newbie at FreePBX. I’ve got FreePBX setup with SIP trunk services from Flowroute. I can make inbound calls to the system and it rings. However after making a call and hanging up, I make another test call and then I get a message “this number is out of service…”. I’m trying to simulate multiple calls back to back to the system and see how it handles. It appears I have to wait some time (20-30 secs) before the system takes my call again. Is there a setting in FreePBX I need to adjust? Or is this a flowroute issue? Additionally, the system only takes calls from cell phones. I cant get through if I make a test call from a landline to FreePBX. I get the same message, “this number is out of service…” Any suggestions is much appreciated.


Look for the incoming calls. I’m going to guess you are going to find “Call rejected from unknown server” or something similar.

If you are not getting any calls in, check your firewall and make sure you have all of the appropriate firewall rules set up.

By default, when Asterisk receives an INVITE from an unrecognized IP address, it routes to an announcement which says (if the default language is English): “The number you have dialed is not in service …” If that’s what you’re hearing, set the Match parameter to allow all Flowroute IP addresses (pjsip trunk) or add additional incoming trunks or aliases (chan_sip trunk).

If you are hearing “out of service”, that message is not from Asterisk. It may be from Flowroute, their CLEC or the caller’s carrier. If the number was recently ported, there could be routing table issues, in which case nothing will be logged at Flowroute for the attempted calls. As caller, contact your landline or mobile operator to complain that the number is not reachable. If the call is logged at Flowroute, possibly your firewall is not allowing traffic from all their server IPs.

If you still have trouble, report what (if anything) is logged at Flowroute and in your Asterisk log for a failing call.

After monitoring the asterisk logs via cli, the calls are not reaching the FreePBX. I opened a ticket with Flowroute and according to them the Sonicwall is not passing SIP traffic from their other PoP servers when attempting subsequent calls. I confirmed the access rules and nat policy settings on the Sonicwall but still have the issue.

I’m going to switch out the Sonicwall with a Edgerouter this weekend to see if it resolves the issue.

Can you please post a picture from your WAN to LAN rule, and your NAT rule, as well as from your VoIP settings?

Have you looked at this thread:

Yes sir. It was his configuration that I used to setup my Sonicwall settings.

Here are the sonicwall settings.

NATRule3 NATRule2

NATRule1 WAN-LAN%20Rule

See below, the destination needs be the WAN Interface not the Private.image

Then you don’t need this.

Why do you need this rule?

Also, do you have PJSIP on TCP?

Initially I had the WAN LAN rule destination pointing to WAN interface and I came across another guide that suggested pointing to internal IP of my FreePBX. I’ll change it back.

I manually created the NAT policies and then I ran public wizard tool and it may have auto created the redundant policy. I’ll get rid of one of them.

PJSIP was on UDP so I’ll change it to TCP.

I’ll make these changes and give it a try later today. Thanks.

Once you have all your address objects, service objects and groups all setup, then It’s technically a two step process.

  1. In Firewall Rules you need to allow that SIP/PBX Service group to your WAN IP. (of course set the Source to your trusted group, like SIP Providers, remote locations etc.)
  2. In NAT rules, you have to set a rule to translate anyone coming to your WAN IP with the SIP/PBX Services to translate to the private IP.

You already have it on TCP…

Still no luck. I’m going to swap out SOnicwall with another router and see if I get the same issue and possibly fire up another FreePBX box.

Just another thought. Did you check the address objects to make sure they are correct?

Update -

After swapping out Sonicwall with another firewall, the issue still remains. I decided to test with another SIP provider (Voyant) and I’m no longer experiencing the issue. I’ve made several test calls back to back without getting the “number out of service” error.

However, I’ve got another strange issue. I can make outgoing calls from behind the FreePBX and the remote end can hear my voice but I’m not able to hear their voice. If the remote end calls me, I can hear their voice and they can hear my voice. Any ideas?

I’ve resolved the audio issue for outgoing. It was NAT rule that was wrong. I can hear audio both ways. I’ll continue to test but thanks all for the input.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.