NOTE:AUTHTYPE is not set to 'database' in /etc/amportal.conf

Hi I installed FreePBX 5 days ago and I love it!
My Version
Asterisk (Ver.

My problem today is that the Web Administrator section to add administrators reports this error;

NOTE:AUTHTYPE is not set to ‘database’ in /etc/amportal.conf - note that this module is not currently providing access control, and changing passwords here or adding users will have no effect unless AUTHTYPE is set to ‘database’.

I cd into /etc/amportal.conf and I can see that AUTHTYPE=database is set properly.

Your help is appreciated.

Hi, I still have this problem and can’t figure it out on my own how to fix it.

I also have a problem with;

Reports - No data, I have tried many different ways
Music on hold - Only plays .wav files no .mp3

Here are my musiconhold.conf & musiconhold_addtitional.conf;

; Music on hold class definitions
; This is using the new 1.2 config file format, and will not work with 1.0
; based Asterisk systems
#include musiconhold_custom.conf
#include musiconhold_additional.conf


Simphony is .mp3 file I upload thru the GUI and I don’t get an error but the file doesn’t get loaded.

I also did not have the folder /mohmp3 so I created it using mkdir

Can someone please help me? If I fix these 3 items I would be set!

how was this box built?

I’m guessing that you don’t have several required files loaded. for reports you need the asterisk-addon’s loaded or the CDR data will not get saved.

for MP3’s to work you need to load the MP3 libraries. But without knowing the details behind how this box it built it’s hard to help.

Here is what I did;

A. Download FreePBX from Live CD
B. followed installation instructions from 15-installation-and.html - I only hanged passwords for Admin & FreePBX per instructions
C. After complete install & password change I upgraded module admin, such as Basic Section, CID & Number Management, Inbound Call Control, Internal Options & Configuration.
D. Last thing I did was to run “yum update”.
E. I have no errors in System Status but when I go into Administrators i have the error; NOTE:AUTHTYPE is not set to ‘database’ in /etc/amportal.conf - It says that the module is not providing access control but if I add a TESTUSER, log off, log in as TESTUSER it works, so I can add Administrator users. I did not try add extensions with TESTUSER.

I agree with you, I think I’m missing asterisk-addon’s & to load MP3 libraries. I spent my whole weekend looking for ways to fix this on my on but just don’t know how.

I appreciate your help!

I just installed asterisk-addons-mysql and CRD Reports work! In terminal I did “yum install asterisk-addons-mysql” did a reboot and that’s it!

I’m down to 2 issues;

  1. NOTE:AUTHTYPE is not set to ‘database’ in /etc/amportal.conf
  2. Music on hold plays only .wav and no .mp3


Please see for a solution

After reading you link and not able to fix my issue NOTE:AUTHTYPE is not set to ‘database’ in /etc/amportal.conf

I came across this other interesting link in Spanish that solved my problem.

To fix my error I edited /var/www/html/admin/modules/core/page.ampusers.php and changed


<?php if (($amp_conf["AUTHTYPE"] != "database") || ($amp_conf["AUTHTYPE"] != "webserver")) { ?>


<?php if (($amp_conf["AUTHTYPE"] != "database") || ($amp_conf["AUTHTYPE"] != "database")) { ?>[/code]

I still had to make this change even though /etc/amportal.conf was set to AUTHTYPE=database.

My last issue is music on hold I need to load the MP3 libraries. I can upload .WAV files but no .MP3 files.

Can someone provide me with information on how to load the MP3 libraries? My PBX Box goes into production environment tomorrow. Thanks!

loan_refi, The link that Mike pointed you to is the proper fix for the AUTHTYPE error. It will be the one that will get rolled out when the next version of the core updates happen very shortly.

I did try the correct fix Mike pointed out to me but as soon as I apply the fix I get a blank screen in Administrators section only and everything else works.

I make a note of this and for when the core updates get released.

Do you happen to know how I can load the MP3 libraries?


load_refi, then you copied something wrong, as I know that patch fixes the issue.

Google is your friend… (the issue is not FreePBX but asterisk so search using that term) note comments for asterisk 1.4

many distros have it in the asterisk-addon’s and/or in the asterisk-mp3 rpm.

Also have you asked or looked at the AsteriskNow forums?

FreePBX is just one component of that distribution and for full support for AsteriskNow you’d be better off checking those forums first.

For the MP3, I did not think of that I’m glad you mentioned it. I will do as you say.

I will also work on the AUTHTYPE Error as you indicated.

For now My PBX is okay but will make it right. A solution for now for MP3 I just simply grab a WAV file to play my music on hold.

Thank you very much for your support!

just ignore the authtype error, it is purely cosmetic and will be pushed out shortly. We are just looking at some other bugs that are related to the core module and want to address those prior to pushing out the next rev of the module.

I was able to fix the problem by typing the following commands as root:
mkdir /var/lib/asterisk/mohmp3
(upload your mp3 files into that directory)
chown -vR asterisk.asterisk /var/lib/asterisk/mohmp3
chmod -v 775 /var/lib/asterisk/mohmp3
chmod -v 664 /var/lib/asterisk/mohmp3/*
yum install asterisk14-addons-core
asterisk -rv
restart when convenient