Not able to see ARI Rest Configuration in FreePBX GUI - Advanced Settings

Recently I installed FreePBX on a GCP VM from GCP Marketplace for evaluation. I wish to configure Asterisk RESTful Interfce (ARI) details and expected to see a section named Asterisk Rest Interface. But, I am seeing only Asterisk Manager soon after "Asterisk mini-Http Server**

I am not able to see that section (Asterisk Rest Interface), even after I made the following changes (Screenshot attached)

  1. Read-Only Setting - Yes,
  2. Override Read Only Settings - Yes
  3. Submit, Apply Config (Red Button)
  4. Restarting Asterisk

It looks like the Free PBX v 15.0.23 with Asterisk v16.10.0 Admin UI is different than whatever explained in the official documentation and forums.

Can someone help me to enable Rest Interface from FreePBX UI?

What section comes after “Asterisk Manager”? It’s totally present in our installations of 15 and we didn’t really need to do anything especial to get it to show up.

Seeing ’ Call Flow Control Module’. I have given my screenshot below with next few sections.

This might be managed by a module but I am honestly not sure which one it would be. Can you check under Admin → Module Admin and see if you have the REST API module installed and enabled?

It’s there

You will have to enable “Display Readonly Settings” and/or “Override Readonly Settings” to see these fields.

Huh, from his initial screenshot it looks like he had those options already enabled but I guess I might be missing something here.

I don’t have a 15 system at hand to check, this might be a feature of 16+.

I do and have and it’s there on our 15 systems.

Yes. Please see the screenshot

Free PBX v 15.0.23 with Asterisk v16.10.0. Installed from GCP Marketplace and configured.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.