Noise / echo with new Draytek Router

Hey all, we recently replaced the default Telstra V7610 modem with a Draytek 2860 Modem,
I have opened up all the ports to match what was on the Telstra router, all phones and our FreePBX registered straight away, however there is quite a bit of noise / echo / beeping noise on the external side of the call.
I am unsure what other setting i need to change on the router.
What i have tried so far.
Applied QOS to SIP/RTP
Enable first priority for VOIP on UDP Port 5060.
Restarted both Router and Freepbx.
Freepbx version 2.11


Disable anything related to SIP ALG.

thank you for the reply, unfortunately it did not help. I searched what you suggested and it sounded exactly like the issues i have, i ran the following command using telnet
To disable SIP ALG type “sys sip_alg 0”

Type “sys commit”

I then rebooted the router and freepbx box, as soon as it all booted back up, all call came through and it was noisy still.
I tested what i done with the following command sys sip_alg ?” and it says disabled.

What was the reason for the modem upgrade? What type of internet do you have? DSL, Cable, Fiber?