No "System Admin" or "manager" modules: Manual Install

I installed FreePBX 13 on CentOS 6 as recommended by this link:

http://wiki.freepbx.org/display/FOP/Installing+FreePBX+13+on+CentOS+6

After fixing a few permissions related bugs it appears to work (not tested with anything, just using the configuration interface.) But I am not able to install iSymphony as it indicates the “manager” module is not installed. Furthermore, I cannot register because there is no “System Admin” module available either. I have added the repository as indicated in the above install link. What do I need to do to get these modules?

Regards,
David Koski

Have you seen this wiki page:
http://wiki.freepbx.org/display/FPG/Installation+on+CentOS+and+RHEL+based+systems

Progress. I overlooked step 4. But installing gives this error:

chmod(): Operation not permitted

I think I can figure it out, though.

Thanks!

David

This has proven to be more difficult to figure out than at first thought. The line referred to in the chmod error is obfuscated. I have no idea what it is referring to.

[EDIT] I ran strace on httpd and found I needed to “chown asterisk: /etc/schmooze”. Then the module install worked.

Thanks, lgaetz!

David

1 Like