No such command 'sip show' -- HELP

I have absolutly no idea why

but i have installed my first FreePBX box

installed 2 X-lite on 2 XP boxes

created 2 extensions - Just to test

they say there registered, but i can’t call each other
after digging around i found the command “sip show peers” to check the registration but it doesn’t work

What is going on ??

Thanks in advance

The command needs to be run from inside asterisk on it’s command linee not on the linus command line. To get to the asterisk command line type asterisk -r

sorry should of explained i did that

all other commands are available but just nothing to do with SIP

if you type help from the CLI it lists loads

from asterisk cli what does

return? If you dont have Session Initiation Protocol (SIP)
Then you need to load it, or rebuild asterisk with sip suppoort, then restart and load it.

We had a short internet connection failure during which we could not make any sip calls. For some reason I though maybe restarting Asterisk would help. Well, it didn’t, and it apparently didn’t reload SIP either, so when the Internet connectivity came back the system still wouldn’t work until I restarted asterisk again. During the interim period any commands associated with sip didn’t work.

Any time you encounter this sort of weirdness, the first thing to do is restart Asterisk (do “restart when convenient” from the CLI if you don’t want to interrupt any calls in progress). If that doesn’t work, don’t mess around, just reboot the Asterisk box (do “shutdown -r now” from the Linux command prompt). If THAT doesn’t work, you have a more serious issue - might be time to try downloading and reinstalling Asterisk (see the “How to Upgrade Asterisk” document in the HowTo section - just get the latest versions of everything in whichever branch of Asterisk you’re currently using) - hopefully that will rebuild or restore any missing or damaged modules.

show modules like sip brought up nothing

then i rebooted

then everything worked

very strange :blush:

I’ve just met your case! I tried to install Asterisk 1.6 from svn, with full features, so I have to install dahdi module first to get MeetMe application. Maybe the kernel need reboot to work properly?
Is it what you did when this happen?

I believe in 1.6 the command is changed to “core sip show peers”.


I just installed AsteriskNOW 1.5b and had the same thing happen. I added a SIP Extension using FreePBX and then ran “amportal restart” from the command line to restart asterisk and everything is working fine. I think that Asterisk does not load the SIP commands if there are no sip extensions. I don’t know if this is a bug or a feature, but…

Also, before i restarted via amportal, the output of the command “show modules like sip” did include

Just thought this info might be helpful for others searching for a solution to this problem.


I’m haing the same problem - I added my first SIP extension after a clean build, but the phone handset would not register - SPA942 handset says “Failed (NotReachable)”. I’m just rebooting my asterisk box (used shutdown -r now) now and…

It works!

I did not do an upgrade to all modules yet - but the roboot fixed it! A reload of the asterisk from the asterisk CLI did NOT fix this.

I just installed Asterisknow 1.7.0 and setup my first extension, it would not register.

From the asterisk CLI help no sip commands showed.

Tshark showed the extension trying to register but no response from the server.

On the off chance I did an Amportal restart and the extension immediately registered and the sip commands have appeared in the CLI help.

It seems until you set up a sip extension and restart asterisk sip is not available. Given that others have experienced this is this a bug in 1.7.0?

it sounds like when it first comes up, the chan_sip is not loaded.

Whether or not this is a bug in AsteriskNOW, don’t know.

I seem top recall something similar occurring in 1.5. I believe a restart of Asterisk regardless of whether you had configured anything or not would have done it. Possibly even just a reload or a manual load of the chan_sip.

None of these helped me with my problem. As it turns out, FreePBX requires certain files to be created EVEN IF THEY ARE EMPTY. In my case, I needed to add the sip_custom_post.conf file back in as an empty file. Then a core restart solved the problem.