No sound when playing back User made System Recordings

Running FreePBX on Asterisk

Made system recordings for producing my IVR using an IP phone extension.
The system answers and logs show that the files have been played but caller only hears silence until the system supplied message “Goodbye” on timeout of keypress is played.

I have associated a feature code with announcement and system recording for testing with the same result.

Copied the .wav files via ftp from sounds/custom/ directory to my workstation and the files play as expected. All permissions and ownerships of custom system recordings have been checked and are identical to the system supplied recordings which play correctly.

Well to start if the info you provided is correct: using asterisk

There have been hundreds and hundreds of bugs found and fixed since that version was released. Please first upgrade to a newer version of asterisk to verify that the first release version of asterisk does not have a bug in it (or spend the time reviewing the release notes to see if it was found and fixed which I’ll bet has been).

now I get a segmentation fault.

Last lines of asterisk -cvvv output as follows: => (Local Proxy Channel (Note: used internally by other modules)) => (ADSI Resource)
== Registered application 'DAHDIRAS’ => (DAHDI ISDN Remote Access Server)
== Registered custom function ‘ENUMRESULT’
== Registered custom function ‘ENUMQUERY’
== Registered custom function ‘ENUMLOOKUP’
== Registered custom function 'TXTCIDNAME’ => (ENUM related dialplan functions)
== Registered file format h263, extension(s) h263 => (Raw H.263 data)
== Registered application 'BackgroundDetect’ => (Playback with Talk Detection)
== Registered custom function ‘GLOBAL’
== Registered custom function 'SHARED’ => (Variable dialplan functions) => (Loopback Switch)
Segmentation fault

addon modules were not compatible with 1.6.1
Dropped back to
Still got the audio playback issue

Anyone got any other ideas?

If I take the sound files I copied to my workstation and do a file upload instead of recording dirctly from an extension the audio plays back fine.

Anyone who can come up with a real fix I’d be glad to hear from.

I got around this by using a dummy extension and then manually moving the recordings to the system recordings directory. It would be nice if this was fixed ASAP. Does anyone have the bug ID?


I’m running asterisk version on ubuntu server with FreePBX 2.6.0RC2. Already had the Problem with FreePBX 2.5.x

I did the following so solve it:

rmdir /var/lib/asterisk/sounds
rmdir /usr/share/asterisk/sounds
ln -s /usr/local/share/asterisk/sounds /var/lib/asterisk/sounds
ln -s /usr/local/share/asterisk/sounds /usr/share/asterisk/sounds
chmod 777  /usr/local/share/asterisk/sounds

I don’t know if this solves your problem but it worked for me.