No SIP Registration with flowroute

I’ve had a Trixbox CE system operating for several years. The computer was showing signs of age so I bought a new system and was advised to install FreePBX, which I did.
I set up the new system modeled after the trixbox settings.
Outgoing calls work but I don’t receive incoming calls.
Flowroute tells me that there is no SIP registration from my system.
I am not an expert in this field and the “expert” who advised me to setup FreePBX is unable to fix it.
I’m sure this is not enough information, but I don’t know what info will help in diagnosing my problem.

No, not enough information but a wild guess. Is the system behind a router?

If so you need to see where UDP 5060 and 10000-20000 are forwarded to. Also check to make sure your NAT settings match your network in the SIP Settings module.

This was all in different places in the old version tribox put their name on.

Yes the system is behind a router. The new system has the same IP address as the old system.
I’ve added UDP 5060 to forward to the PBX, and
I’ve added UDP 10000-20000 to forward to the PBX.

The NAT settings are:
NAT - Yes
IP Config - Static IP
External IP - 70.nnn.nnn.nnn (my public static ip)
Local Networks:
1.0 is my dmz where the VoIP box resides.
0.0 is the LAN where my workstations and phones are networked.

My firewall from the dmz to the Internet is OpenWrt White Russian. It has a peculiarity in that it does not allow loopback (that is, a computer on the LAN can’t hit its own external IP address and have the packet forwarded back as if it had come from the outside." Could this be causing a problem? It did not disrupt the trixbox system.

This should be very easy to troubleshoot.

If by “outgoing calls work”, you mean using the same Flowroute account as you are attempting to use for incoming, then IMO a router or firewall issue is very unlikely, because the REGISTER requests and responses will be using the same addresses and ports as the outgoing INVITEs.

Are you using the same Flowroute credentials on the old and new systems? If so, that’s a conflict for incoming. To test the new system, you must first shutdown the old one, then restart Asterisk on the new one.

Next, check that Register String is set correctly for the trunk. It should have the same username and secret as your outbound settings.

At the Asterisk command line, type
sip show registry

and report what is shown for Flowroute.

If it shows registered, report what the caller hears and what gets logged on an attempted incoming call.

Stewart that statement doesn’t not make sense. Not sure what you are trying to say.

RFEngineer (are you really) simply post the log for a failing call.

You can also react your credentials and post trunk settings.

The same flowroute account is being used for in and out routes.
I have two SIP trunks defined, one for each of my DIDs. The PEER details are cut & pasted from the flowroute “System Configurator”. Same with the registration string. Flowroute’s tech support looked at the config and said it was correct.
I have a single outbound route with my two trunks referenced.
I have two inbound routes one for each DID with different CID name prefixes and routing to different ring groups.
I had the old system shut down but brought it back on line with a different IP address so I could compare settings. I have now disconnected it from the network and rebooted the new server.

I sent sip show registry using Asterisk CLI and got this response:

Host dnsmgr Username Refresh State Reg.Time N 23433805 105 Registered Sat, 07 Jun 2014 19:44:26
1 SIP registrations.

WOO HOO!! I’m registered!

It rings into my system, but not all the correct extensions are ringing, but that is an entirely new matter. I can fix that, it was the registration problem that had me flummoxed.

Thank you and mark this problem SOLVED! (of course I have no idea what we did to fix it… but THANKS!)

Skyking, Yes I am an RFEngineer. What I am not is a Linux/Asterisk expert. I only know enough about this stuff to be dangerous.

I had SIP registration this morning. While I was adjusting extension settings, because not all the extensions were working properly, the SIP registration went away. Again, I have no incoming calls!
What the heck is going on?? Could changes to extension settings do this?
I am not a Linux or Asterisk person, so if a log of a failed call is needed I will need instructions on how to obtain one.

When the phones lose registration can you still ping them.

What if you ‘service iptables stop’ to stop the built in firewall?

Flowroute has excellent customer support. Open a ticket on their web-site, or call them during business hours, and their techs will get you up and running very quickly.

I’ve had a ticket open with flowroute on this problem since last week. They have been of very little help.

Let’s start off with a simplified drawing of my network:
This is the same configuration I’ve had for years with the TrixBox system.
There are no routes to the freePBX box through the Cisco Router.
I’ve forwarded port 5060 plus range 10000-20000 through the White Russian Router to the freePBX box.
I have a single static IP from the Cable Modem.
The freePBX box in the DMZ cannot ping the phones in the LAN. Devices in the LAN can ping the freePBX box.
I can connect to the freePBX box from the LAN with a web browser and with SSH (putty).
I’ve tried replacing the White Russian router with a new, simple router. There was no change in the symptoms.
I sent the ‘service iptables stop’ command via SSH and there was no change in the symptoms.
Presently I cannot make incoming or outgoing calls. I am not opposed to wiping out everything on the freePBX box and starting with a fresh install, in fact I have done that once already.
What additional information would be helpful?

I had an issue with a provider (not Flowroute) that I no longer use. Conceivably, Flowroute is doing the same thing: Normally, the client device would register once per hour. If it sent an extra REGISTER request more than ~ 3 minutes before expiry, their SBC would intercept the request, i.e. not forward it to their server, and send back a dummy 200 OK response, showing a one-hour expiry. Now, Asterisk restarts its registry procedure whenever the configuration is reloaded, typically after every change. So, if e.g. you changed something (whether or not related to the trunk) 40 minutes into the cycle, the new REGISTER would have no effect and registration would expire 20 minutes later; incoming calls would stop working. If you left everything alone, operation would return to normal 40 minutes later, when Asterisk sent the next REGISTER request. However, the provider also denied (with 403 Forbidden) outbound calls if you weren’t registered. And, just to be extra mean, if you sent too many Forbidden requests, e.g. because you retried the failing outbound call a few times, they would ban your IP address for half an hour, often blocking the next registration attempt!

If you looked at the SIP traffic, you could tell this was happening, because the fake response was given immediately, without challenging for authorization with a 401 or 407.

I bought this computer a year ago to replace the aging TrixBox system. My regular IT guy, who contracts with a bunch of us small businesses, had it for all that time trying to get it set up. I finally gave up on him and took the machine back. I am trying to get it running myself. I’m a technical person but am NOT knowledgeable regarding Linux and Asterisk. I hope to have a NEW IT guy lined up in a few weeks but since the TrixBox system failed I have been without a working phone system, a bad thing for a small business. I am receiving calls only because I have a failover route set with flowroute to send my calls to my cellphone.
Any help someone could give me in getting this system working would be greatly appreciated.
With respect to the Wiki, I have read and tried to implement the process outlined in the getting started section, but someone other than me initially set up the system. Would it be worth trying to wipe out everything and start over from scratch??
Feedback? suggestions??

  1. can you ping your provider from the pbx?
  2. if you save the trunk in freepbx and then hit apply, does the pbx register for a short period of time? check with sip show registry.

Yes, I can ping from the pbx.
No, I saved the trunk and did a sip show registry and the system did not indicate that it was registered.

Flowroute tech support is following a similar path, they just asked me to do a tcpdump while saving the trunk configuration.

Tell me, does the CLI command ‘sip reload’ do the same thing?

I sent a tcpdump to flowroute and they responded with:

I analyzed your packet capture; there is solely internal signaling between your Linphone and your FreePBX. There is a REGISTRATION request from your Linphone to your FreePBX but no REGISTRATION from your FreePBX to Flowroute. If you were able to reload your configuration to attempt to trigger a REGISTRATION request from your FreePBX it looks as though your FreePBX is not sending registrations. If your FreePBX does not send REGISTRATIONs to Flowroute, we will not know where your system is located.

If your FreePBX is not sending REGISTRATION requests, you will need to review your configuration to determine why it is not sending REGISTRATION requests. You may need to wipe the configuration and rebuild it.

I have gone through the setup guidelines in the wiki’s “First Steps after Installation” and I thing everything is configured correctly.
What could cause freePBX to not send registration requests?

Not sure, did you try turning off the FreePBX firewall and see if it helps?

‘service fail2ban stop’ ‘service iptables stop’ reverse order to start again.

I tried your suggestion. I stopped fail2ban and iptables.
There was no SIP registration.
I made an outgoing call. The call went through but still no SIP registration.
I made an incoming call. The call went to my failover route (cellphone).
I sent sip reload via the Asterisk CLI, still no SIP registration.

You you please post the output of SIP show registry?