No sip codec selection of "disallowed" or "allowed" in extension page config works

Freepbx distro with Freepbx 12 and asterisk 12 with all updates.

Under Settings/Asterisk Sip Settings I have ulaw and gsm as the only allowed codecs.

When I enter disallowed=all and allowed=ulaw in the extension configuration the eyebeam softphone I am using will register but not make calls because of codec errors. When I have disallowed= and allowed= left blank the softphone extension works perfectly. (Softphone codec allowed is ulaw only.)

Note the error messages below that result when disallow=all allow=ulaw is the setting on the extension configuration page. No calls are possible with this config.

Should it matter if your Settings/Asterisk Sip Settings and extension config make the same disallow and allow settings?

[2014-09-30 10:11:31] VERBOSE[9976][C-0000000a] pbx.c: – Executing [[email protected]:1] Answer(“PJSIP/780-00000006”, “”) in new stack
[2014-09-30
10:11:31] WARNING[12316] res_pjsip_sdp_rtp.c: No joint capabilities
between our configuration((nothing)) and incoming SDP((ulaw))
[2014-09-30 10:11:32] VERBOSE[9976][C-0000000a] pbx.c: – Executing [[email protected]:2] Wait(“PJSIP/780-00000006”, “1”) in new stack
[2014-09-30 10:11:32] WARNING[9976][C-0000000a] channel.c: Unable to find a codec translation path from (nothing) to (slin)
[2014-09-30 10:11:32] ERROR[9976][C-0000000a] channel.c: Could not set write format to SLINEAR
[2014-09-30 10:11:33] VERBOSE[9976][C-0000000a] pbx.c: – Executing [[email protected]:3] NoOp(“PJSIP/780-00000006”, " original caller id is 780") in new stack
[2014-09-30 10:11:33] VERBOSE[9976][C-0000000a] pbx.c: – Executing [[email protected]:4] GotoIf(“PJSIP/780-00000006”, “1?noplus”) in new stack
[2014-09-30 10:11:33] VERBOSE[9976][C-0000000a] pbx.c: – Goto (custom-meetme,s,6)
[2014-09-30 10:11:33] VERBOSE[9976][C-0000000a] pbx.c: – Executing [[email protected]:6] NoOp(“PJSIP/780-00000006”, "using callerid as 780 ") in new stack
[2014-09-30 10:11:33] VERBOSE[9976][C-0000000a] pbx.c: – Executing [[email protected]:7] Set(“PJSIP/780-00000006”, “password=”) in new stack
[2014-09-30 10:11:33] VERBOSE[9976][C-0000000a] pbx.c: – Executing [[email protected]:8] Set(“PJSIP/780-00000006”, “pswdloop=1”) in new stack
[2014-09-30 10:11:33] VERBOSE[9976][C-0000000a] pbx.c: – Executing [[email protected]:9] Playback(“PJSIP/780-00000006”, “agent-pass”) in new stack
[2014-09-30
10:11:33] WARNING[9976][C-0000000a] channel.c: Unable to find a codec
translation path from (nothing) to (gsm|ulaw|alaw)
[2014-09-30 10:11:33] WARNING[9976][C-0000000a] file.c: Unable to open agent-pass (format (nothing)): Function not implemented
[2014-09-30 10:11:33] WARNING[9976][C-0000000a] app_playback.c: Playback failed on PJSIP/780-00000006 for agent-pass
[2014-09-30 10:11:33] VERBOSE[9976][C-0000000a] pbx.c: – Executing [[email protected]:10] Read(“PJSIP/780-00000006”, “digit,1,1,20”) in new stack
[2014-09-30 10:11:33] VERBOSE[9976][C-0000000a] app_read.c: – Accepting a maximum of 1 digits.
[2014-09-30 10:11:33] WARNING[9976][C-0000000a] channel.c: Unable to find a codec translation path from (nothing) to (slin)
[2014-09-30 10:11:33] ERROR[9976][C-0000000a] channel.c: Could not set write format to SLINEAR
[2014-09-30 10:11:34] VERBOSE[9976][C-0000000a] app_read.c: – User disconnected

There is an error in your problem statement. Either you haven’t enabled ulaw in sip.conf (or cancelled it by putting disallow=all after it), or the phone is not configured to use mu-law.

Your debug level isn’t high enough to see what is actually being offered or what you are actually prepared to accept.

Thanks for the reply.

Your reply is interesting because I never edited the sip.conf personally. Any changes to sip.conf would be made by Freepbx from the entries I made on the Settings/Asterisk Sip Settings or the Applications/Extensions page. Somehow Freepbx is causing the conflict to occur.

If you want more info from me, I will be happy to provide it.