No RTP from PBX for Outbound call, No Audio

Hi,

I’m quite new to this FreePBX/Asterisk, trying to set up a SIP call using a softphone on my Laptop.

Flow - Softphone -> Internet -> PBX on Azure -> Provider

While making an outbound call, Invite messages (with SDP) are acknowledged by the PBX with 200OK(SDP), the the provider end is sending RTP requests, but FreePBX doesn’t send any RTP.

Can you please help.

Azure Setup :
eth0 : Management IP (172.6.X.X)
eth1 : Signalling ( 10.20.Y.Y)
eth1.Public : 20.20.Z.Z (Created post installation as there was no public IP assigned by Azure for this VM)

Asterisk SIP Settings ( NAT Settings)
External Address : 20.20.Z.Z
Local Address : 10.20.Y.Y
172.6.X.X
RTP Port Range : 10000-12000

Chan_PJSIP Settings : UDP Enabled for both 20.20.Z.Z & 10.20.Y.Y for ports 5060

Any help on this would be appreciated.

What does the provider SDP contain? Where are you monitoring RTP inbound to Asterisk from your end? Where are you monitoring RTP outbound to the provider?

Invite from PBX:

Session Initiation Protocol (INVITE)
Request-Line: INVITE sip:[email protected]:5060 SIP/2.0
Message Header
Via: SIP/2.0/UDP 10.20.Y.Y:5060;rport;branch=a628-ff3c7d770b38
From: “Extension1” sip:[email protected];tag=b341512df19b
To: sip:[email protected]
Contact: sip:[email protected]:5060
Call-ID: dc4bca464072
[Generated Call-ID: dc4bca464072]
CSeq: 15102 INVITE
Allow: OPTIONS, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL, UPDATE, PRACK, MESSAGE, REFER
Supported: 100rel, timer, replaces, norefersub, histinfo
Session-Expires: 1800
Min-SE: 90
P-Asserted-Identity: “Extension1” sip:[email protected]
Max-Forwards: 70
User-Agent: FPBX-15.0.17.12(16.15.1)
Content-Type: application/sdp
Content-Length: 382
Message Body
Session Description Protocol
Session Description Protocol Version (v): 0
Owner/Creator, Session Id (o): - 8081 IN IP4 10.20Y.Y
Session Name (s): Asterisk
Connection Information ©: IN IP4 10.20.Y.Y
Time Description, active time (t): 0 0
Media Description, name and address (m): audio 10900 RTP/AVP 0 8 18 3 111 9 101
Media Attribute (a): rtpmap:0 PCMU/8000
Media Attribute (a): rtpmap:8 PCMA/8000
Media Attribute (a): rtpmap:18 G729/8000
Media Attribute (a): fmtp:18 annexb=no
Media Attribute (a): rtpmap:3 GSM/8000
Media Attribute (a): rtpmap:111 G726-32/8000
Media Attribute (a): rtpmap:9 G722/8000
Media Attribute (a): rtpmap:101 telephone-event/8000
Media Attribute (a): fmtp:101 0-16
Media Attribute (a): ptime:20
Media Attribute (a): maxptime:150
Media Attribute (a): sendrecv
[Generated Call-ID: dc4bca464072]

The 200 OK(SDP) response from the Provider

Session Initiation Protocol (200)
Status-Line: SIP/2.0 200 OK
Message Header
Session-Expires: 1800;refresher=uas
Require: timer
Via: SIP/2.0/UDP 10.20.Y.Y:5060;rport=5060;received=10.20.Y.Y;branch=z9hG4bKPj1cbf3164-433b-4ca8-a628-ff3c7d770b38
To: sip:[email protected];tag=3843641235-149706318
From: “Extension1” sip:[email protected];tag=b341512df19b
Call-ID: dc4bca464072
[Generated Call-ID: dc4bca464072]
CSeq: 15102 INVITE
Allow: MESSAGE,PRACK,SUBSCRIBE,REFER,INFO,NOTIFY,REGISTER,OPTIONS,BYE,INVITE,ACK,CANCEL
Contact: sip:[email protected]:5060
Content-Type: application/sdp
Accept: application/sdp
Content-Length: 217
Message Body
Session Description Protocol
Session Description Protocol Version (v): 0
Owner/Creator, Session Id (o): TEST-UK 3913 1 IN IP4 10.25.P.P
Session Name (s): sip call
Connection Information ©: IN IP4 10.25.P.A
Time Description, active time (t): 0 0
Media Description, name and address (m): audio 36062 RTP/AVP 0 101
Media Attribute (a): rtpmap:0 PCMU/8000
Media Attribute (a): rtpmap:101 telephone-event/8000
Media Attribute (a): fmtp:101 0-15
Media Attribute (a): sendrecv
[Generated Call-ID: dc4bca464072]

I’m using TCPDUMP/Asterisk for monitoring the RTP on the VM.

The RTP might not be arriving at Asterisk, as tcpdump captures before the the Linux firewall, so please use “rtp set debug on” at the Asterisk CLI, to see if the RTP is actually arriving (and if it is being forwarded.

Is there a valid route to 10.20.P.A?

I notice you are offering G.729. Is G279 being used in your network and do you have enough codec licences to cover the transcoding to the provider’s µ-Law?

Also you SDP is an interpretation of the SDP, not the actual SDP, although I don’t think any information is missing.

RTP Packets :
CLI> rtp set debug on
RTP Packet Debugging Enabled

== Setting global variable ‘SIPDOMAIN’ to ‘20.20.Z.Z’
== Using SIP RTP Audio TOS bits 184
== Using SIP RTP Audio CoS mark 5

-- Executing [[email protected]:1] Set("PJSIP/4422YYYYY-00000016", "CALLERID(num)=+4422YYYYY") in new stack
-- Executing [[email protected]:2] Dial("PJSIP/4422YYYYY-00000016", "PJSIP/TRUNK1/sip:[email protected]:5060") in new stack
-- Called PJSIP/TRUNK1/sip:[email protected]:5060
-- PJSIP/TRUNK1-00000017 is ringing
-- PJSIP/TRUNK1-00000017 is ringing
-- PJSIP/TRUNK1-00000017 answered PJSIP/4422YYYYY-00000016
   > 0x7f33d800d2e0 -- Strict RTP learning after remote address set to: 10.25.P.A:36208
   > 0x7f33d8046450 -- Strict RTP learning after remote address set to: 106.B.B.B:12750
-- Channel PJSIP/TRUNK1-00000017 joined 'simple_bridge' basic-bridge <aa4495eb-0229-4475-985f-eff9dee7e599>
-- Channel PJSIP/4422YYYYY-00000016 joined 'simple_bridge' basic-bridge <aa4495eb-0229-4475-985f-eff9dee7e599>

-- Channel PJSIP/4422YYYYY-00000016 left 'simple_bridge' basic-bridge <aa4495eb-0229-4475-985f-eff9dee7e599>

== Spawn extension (from-pstn1, 004411XXXXXXX, 2) exited non-zero on ‘PJSIP/4422YYYYY-00000016’
– Channel PJSIP/TRUNK1-00000017 left ‘simple_bridge’ basic-bridge

Yes there is a valid route to 10.20.P.A.

Note: 106.B.B.B is my laptop’s public IP.

Currently offering both G729 & mu-law, but we can just offer Code mu-law to get this working.

You don’t seem to have any RTP reaching Asterisk from either side. If you are seeing it on tcpdump, check that that you don’t have a firewall rule against it and check that is is addressed to the port that Asteirsk sent towards your side, in its SDP.

i’d wager you have the Sip external IP set wrong.

Contact: sip:[email protected]:5060

this catches so many people. most likely you havent set your External IP in sip general settings or PJSIP settings.

both your SDP and Contact header are telling the other end to contact a Private, non-routable IP Address.

Some ISPs seem to provide SIP service over private addresses, which is why I didn’t challenge this. On the other hand, I did wonder why they bothered to obfuscate network 10 addresses.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.