No ringtone if destination is a ring group


yesterday switched to asterisk 13 (from asterisk 11).
freepbx distro 10.13.66-22.

Today i have this problem:

i have some inbound route with ring group as destination. When a call arrive, no ringtone is prompted.
This happens only for external incoming call.

maybe related to asterisk 13?

1 Like

What do you have selected here:

It’s possible for it to have no ring tone in ring groups now.

same as you, (squillo = ring)

but if i call the ring group number from other extension, ring is prompted.

Problem appear only with external call from a trunk

Hum, strange. I definately don’t have that.

Is there a phone connected to the ring group that is not busy so it is able to ring and not go to time out destination right away? Is your freepbx fully updated? Along with “yum update”?

yes, modules fully updated.

I have 10 ring groups, all with same problems.
All phone connected to ring group ring normally.

This has sounds like a problem that’s been reported before. Seems to me there was a lot of discussion on this a couple of months ago. I don’t remember the resolution, or even if there was one.

The logs will tell you what is actually happening, so maybe you could show us a call where the caller doesn’t hear a ring tone? Also, since this sounds like a bug, if you don’t get some kind of resolution on it in the next couple of days, maybe you should submit a ticket. In fact, if you check on the website (where tickets are submitted), you might find the ticket where this was worked on last fall.

ok but I dont understand if this is an asterisk bug or a freepbx bug… because with asterisk 11 and same freepbx version there is no problem…

Since you upgraded, did you try to create a new ring group?
Also, did you check the logs?

yes… same problem also with a new ring group.

Tomorrow iI’ll check the log…

thank you

It doesn’t matter. Check the ticket database through the Issues tab to see if something has been reported here. The reason I’m suggesting that is because I’ve heard about this before, so it’s been reported here (I don’t follow the Asterisk forums). Check the FreePBX issues - if it’s there, see what they said. If it isn’t, submit a ticket, especially since it was working and now it isn’t. Even if it is an Asterisk bug, the FreePBX developers work closely with them and can coordinate a solution for you.

ok solved…

in ring group configuration, set “SEND PROGRESS” to NO

thanks to everyone!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.